UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Absent Member.
Absent Member.

APPDATALOCAL error on launching zav-app

I keep getting the error :

Novell ZENworks Application Virtualization
The application sandbox location @APPDATALOCAL@\Novell\Sandbox\app.name\version\datetime is not accessible. Please check the location and try again.

This error also occurs with the 7-zip template. If I run the virtualized application with admin rights and policy there is no problem. Only in a locked down situation the above error comes up.

Which policies can be responsible for this behavior ?
Tags (3)
4 Replies
Absent Member.
Absent Member.


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team

Absent Member.
Absent Member.


Just pointed the sandbox location to C:\ZAV_temp and not to @appsdatalocal@
Absent Member.
Absent Member.

I ran into this problem... I am pretty sure it has to do with the name of the exe when you build.

I know it doesn't like to build the final virt exe with spaces... I am pretty sure this was the error I was getting and couldn't figure out. The - could be causing the same thing.

Once I changed the virt exe to a short name no spaces it built fine. I then was able to just rename the exe to the name I wanted and it ran just fine.

Though since your problem somes up once you lock down its probably a rights issue.

on XP the default sandbox location is %userprofile%\local settings\Application Data... Your users may not have proper rights to write there (not sure why) but you could check by trying to create/add folders/files and edit them...

If you are running a multiuser enviroment you probably want to keep the sandbox in the %userprofile% somewhere. This way users could customize their apps rather then keep stomping on each others settings. Not an issue if you are deleting the sandbox after use of course.
Absent Member.
Absent Member.

I think this is because its a roaming path.
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.