bentinker Absent Member.
Absent Member.
5884 views

IE 11 Virtual App won't run

Greets.
We are currently testing Zenworks Application Virtualization. So far everything we've built has worked except for Internet Explorer 11. It seems to run then close straight away, sometimes you see a flash on the screen.

This application is why we decided to try ZAV in the first place. If we can't get this to work then that will be the end of ZAV for us.

Any ideas?

Windows 7 Enterprise 64bit.
0 Likes
9 Replies
Anonymous_User Absent Member.
Absent Member.

Re: IE 11 Virtual App won't run

Try executing it with "Run As Administrator" and see if that helps.
This helped me with some of my IE Apps.

If it does, you can virtualize that as well, and it does not really
grant admin rights nor generate a UAC Prompt.


On 6/29/2014 7:36 PM, bentinker wrote:
>
> Greets.
> We are currently testing Zenworks Application Virtualization. So far
> everything we've built has worked except for Internet Explorer 11. It
> seems to run then close straight away, sometimes you see a flash on the
> screen.
>
> This application is why we decided to try ZAV in the first place. If we
> can't get this to work then that will be the end of ZAV for us.
>
> Any ideas?
>
> Windows 7 Enterprise 64bit.
>
>



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Technical Support Engineer

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
0 Likes
bentinker Absent Member.
Absent Member.

Re: IE 11 Virtual App won't run

I've already tried that. No luck.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IE 11 Virtual App won't run

An SR would likely be the best way to go.
I know folks have virtualized IE 11.


On 6/30/2014 6:46 PM, bentinker wrote:
>
> I've already tried that. No luck.
>
>



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Technical Support Engineer

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
0 Likes
drwilliams152 Absent Member.
Absent Member.

Re: IE 11 Virtual App won't run

bentinker;2324526 wrote:
I've already tried that. No luck.


Any luck with this yet? I'm experiencing the same symptoms and am trying to find the cause. Using the IE11 template in ZAV Studio the published app runs on the build machine just fine, but if I move the virtual app to another machine the app window just flashes on the screen and disappears. I ran the exe in diagnostic mode but I'm not seeing any significant differences between a successful launch and a failed launch.
0 Likes
katiefinn Absent Member.
Absent Member.

Re: IE 11 Virtual App won't run

drwilliams152;2328311 wrote:
Any luck with this yet? I'm experiencing the same symptoms and am trying to find the cause. Using the IE11 template in ZAV Studio the published app runs on the build machine just fine, but if I move the virtual app to another machine the app window just flashes on the screen and disappears. I ran the exe in diagnostic mode but I'm not seeing any significant differences between a successful launch and a failed launch.


I'm having the same problem using the IE9 template. Did you get anywhere yet?
0 Likes
Knowledge Partner
Knowledge Partner

Re: IE 11 Virtual App won't run

Do we have any update about this "old" issue?

I tried to create IE11 vapp (ZAV11.2).
From beginning I didn't see any issue: built vapp from IE11 template, app successfully started on "build" machine without any issue. (Win7 box with IE11).
Copied this app to another Win7 box with IE8. IE11 "started", but didn't allow to open "option" menu and any another menu. 😞

Now I realize, that issue is much bigger than my "local" case: after viewing this thread, I started doubt, that it is possible. 😞
I hope, that I'm wrong and we will be able to do it. 🙂

Alex
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IE 11 Virtual App won't run

I actually was able to create one and I added a JAVA shim to it. it was for
standardized testing (PARCC) issues. I was tired of having my techs touch
all possible testing computers in the system out of 9600 devices. So I
created it with the needed settings. But I noticed it was interacting with
the local install and it was messing it up. I opened an SR and they came up
with the solution below which worked. I do use a VM to create my ZAV's. this
keeps it pristine. Below is what you will need to make sure it is a true
virtual app. My IE was 800MB and the JAVA shim was about 350MB so it was a
pretty big Vapp.

Isolate Host IE Add-ons
To completely isolate all host add-ons from the virtual version of IE it is
necessary to fully isolate the registry keys where the add-ons are
referenced.
Part 1: Remove the relevant keys from the IE configuration
Delete the following registry keys (if present) from the Spoon Studio
configuration for IE.
- [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext]
-
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser
Helper Objects]
- [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Ext]
-
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser
Helper Objects]
-
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Ext]
-
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\Browser
Helper Objects]
Part 2: Import the isolation registry keys
Import the attached registry file into the configuration
(isolate-ie-plugins.reg).
Part 3: Set the keys to full isolation
Set the following keys to full isolation.
- [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext]
-
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser
Helper Objects]
- [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Ext]
-
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser
Helper Objects]
-
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Ext]
-
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\Browser
Helper Objects]
Part 4: Build and test the IE package
Build the Spoon Studio IE configuration and test it on a machine that has IE
plugins installer. Verify that the plugins are not loaded.


these are the keys to import

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext]

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser
Helper Objects]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Ext]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser
Helper Objects]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Ext]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\Browser
Helper Objects]

"al b" wrote in message news:al_b.7ayi4n@no-mx.forums.microfocus.com...


Do we have any update about this "old" issue?

I tried to create IE11 vapp (ZAV11.2).
From beginning I didn't see any issue: built vapp from IE11 template,
app successfully started on "build" machine without any issue. (Win7 box
with IE11).
Copied this app to another Win7 box with IE8. IE11 "started", but didn't
allow to open "option" menu and any another menu. 😞

Now I realize, that issue is much bigger than my "local" case: after
viewing this thread, I started doubt, that it is possible. 😞
I hope, that I'm wrong and we will be able to do it. 🙂

Alex


--
al_b
------------------------------------------------------------------------
al_b's Profile: https://forums.novell.com/member.php?userid=12514
View this thread: https://forums.novell.com/showthread.php?t=477998

0 Likes
Knowledge Partner
Knowledge Partner

Re: IE 11 Virtual App won't run

Thank you for your update, CCPS!
I will try to repeat your steps! 🙂
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IE 11 Virtual App won't run

IE11 vapp (ZAV11.2) is better than vapp from IE11 template as I didn't see any issue from beginning but copied this app to another Win7 box with IE8. IE11 the issue started.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.