Highlighted
Super Contributor.. J. Singh Super Contributor..
Super Contributor..
1133 views

Diagnostics 9.20 Java Agent Invoke issue

Dear Experts,

 

    I am new for HP Diagnostics, so need your help.

    I have installed Diagnostics 9.20  commander on windows 2008 platform. Now i want to monitor one Java appliaction.For this i installed Diagnostices Java agent 9.20 on application server. Configured this java agent to connect diagnostics server as enterprise AM mode. I did instrumentation for this and required JVM parameter inserted in application startup file. Restarted application serrver.

 

     I checked diagnostics server side , agent is not showing connected.

     For the same , i checked log folder inside java agent installation directory, there are no logs. 

 

     I am suspecting , that agent is still not invoked , but not able to troubleshoot as logs not geneeration in agent side.

    Please let me know if you can explain this using BSM ( Business Service Mnagament ) as monitored application, then where to insert JVM parameter?

 

    Thanks in advance !!

 

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to Diagnostics Software Support and News Forum - HP Forums moderator

Tags (1)
0 Likes
3 Replies
KMadan Acclaimed Contributor.
Acclaimed Contributor.

Re: Diagnostics 9.20 Java Agent Invoke issue

It seems like you didnt input the parameter at the correct location. Typically, you need to pass it as a JVM parameter. If you can share your startup script/file, we may verify it.

0 Likes
Shakthi Absent Member.
Absent Member.

Re: Diagnostics 9.20 Java Agent Invoke issue

Hi,

 

hopefully u need to do the modiifcation with  regedit java agent.

 

 

Regards,

Durai

0 Likes
Ravi17 Frequent Contributor.
Frequent Contributor.

Re: Diagnostics 9.20 Java Agent Invoke issue

Hello,

 

I am also facing same issue right now. We have installed and configured diagnostics java agent 9.20 on aix 6.1 and WebSphere 7.0.0.11 application server but issue occurs when we add intrumented path in generic jvm argument box but unable to restart WebSphere it got stuck. Please let me know if any addition settings are required at WebSphere side.

 

It would be very helpful for me if you provide any Solution. It is very important here..

 

Thanks in Advanced.....

 

 

Regards

Ravi. 

Tags (1)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.