Highlighted
Absent Member.
Absent Member.
1322 views

IKJEFT01 do not recognize system DSN

Jump to solution

say for the follwoeing JCL snippet, when i am running this, where PROGRAM1 is a simple COBOL DB2 program

//STEP01 EXEC PGM=IKJEFT1B
//SYSPRINT DD SYSOUT=*
//SYSTSPRT DD SYSOUT=*
//SYSTSIN DD *
DSN SYSTEM (INGG)
RUN PROGRAM (PROGRAM1)
END
//

I am getting:-

Micro Focus ESMVS/TSO Version 7.0.000. Copyright (C) 1997-2015 Micro Focus.              All rights reserved.                         
 DSN SYSTEM (INGG)                                                                                                                    
 RUN PROGRAM (TCFAUTRF)                                                                                                               
MVSER0031S "INGG" is not a valid subsystem id. Sub-command stream flushed.:                                                           
MVSER0099S Remainder of command stream flushed.:                                                                                      
 END              

even though INGG is already defined as a system DSN . please advise on the root cause of this
Tags (2)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.
Hi Sunilmh,
You will need to define an XA resource with the ID of INGG in the region configuration. For a DB2 database your XA resource would use the ESDB2XA module. There is some information on configuring the module in the docs, look for Using XA-compliant Resources (XARs)

View solution in original post

0 Likes
4 Replies
Highlighted
Absent Member.
Absent Member.
Hi,

have you definded "INGG" as XA resource ?
0 Likes
Highlighted
Absent Member.
Absent Member.
INGG is defined as ODBC DSN but its related in XA resource 'POCD' using open string parameters
0 Likes
Highlighted
Absent Member.
Absent Member.
Hi Sunilmh,
You will need to define an XA resource with the ID of INGG in the region configuration. For a DB2 database your XA resource would use the ESDB2XA module. There is some information on configuring the module in the docs, look for Using XA-compliant Resources (XARs)

View solution in original post

0 Likes
Highlighted
Absent Member.
Absent Member.
ohh... i have renamed the XA to INGG and i worked... !!! thanks andrew
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.