Highlighted
Contributor.
Contributor.
166 views

10.1 won't execute on HP-UX

Jump to solution

We were testing upgrading from 6.2 to 10. When running runcbl we get the message "sh: runcbl: Execute permission denied." The file is protected 777.

When I do a file command:

[d1::/opt/acucobol62/bin]grs20 test $ file runcbl

runcbl:         ELF-64 executable object file - PA-RISC 2.0 (LP64)

[d1::/opt/acucobol1001/bin]grs20 test $ file runcbl

runcbl:         ELF-64 executable object file

Does anyone know what this means. The version 10 file doesn't state the PA-RISC 2.0 part.

 

 

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: 10.1 won't execute on HP-UX

Jump to solution

133 is an IA build not PARISC

acu_name='HP-UX 11.23 (64-bit) IA-64'
port_machine_key=133

View solution in original post

5 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: 10.1 won't execute on HP-UX

Jump to solution

Good morning.

Please try the following command-lines:

ls -ltr runcbl

and then:

runcbl -vv

777 are attributes of each single file in a Linux/UNIX system.
It may be that your system requires a lower set of attributes.
Try changing runcbl attributes to 755, by using the following command:

chmod 755 runcbl 

Please, find more information in the ACU Documentation: http://bit.ly/2TKXpxz

If the error still persists, I suggest you to contact Micro Focus Customer Care,
by sending an email to customercare@microfocus.com, 
or reporting an Incident on the SupportLine web site: https://supportline.microfocus.com/

Best Regards.

----------------------------
Claudio Contardi
Product Support Engineer, Senior
Micro Focus
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: 10.1 won't execute on HP-UX

Jump to solution

Can you tell me the archive name you have extracted

should be something like setup_acucob10pmk##xxACU

the ## are the version number and xx should indicate whether the build is static or shared

checking mine I see

file runcbl
runcbl: PA-RISC1.1 shared executable dynamically linked dynamically linked

0 Likes
Highlighted
Contributor.
Contributor.

Re: 10.1 won't execute on HP-UX

Jump to solution

Thanks for the reply!

acucob1001pmk133st.tar is what I started with.

[d1::/home/jcampbel]grs19 prod $ model
9000/800/L3000-8x
[d1::/home/jcampbel]grs19 prod $ getconf KERNEL_BITS
64
[d1::/home/jcampbel]grs19 prod $ file runcbl
runcbl: ELF-64 executable object file

 

 

 

 

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: 10.1 won't execute on HP-UX

Jump to solution

133 is an IA build not PARISC

acu_name='HP-UX 11.23 (64-bit) IA-64'
port_machine_key=133

View solution in original post

Highlighted
Contributor.
Contributor.

Re: 10.1 won't execute on HP-UX

Jump to solution
Right there in the small print. They sent the wrong version. Thanks much for the help!!!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.