Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Daniel7 Absent Member.
Absent Member.
2539 views

AcuXDBC Network Connection lost

Jump to solution

At very complex queries with WHERE-clauses and joins between any tables I do not get any successful answer by AcuXDBC Server. I get message "Network Connection lost (recv) Unknown error". Can anyone tell me why this exception throwing? I suspect, it is a timeout from (AcuXDBC) System, but where can I change timeout settings?

Simple queries without WHERE-clauses and joins work successful.

Thanks.

Tags (2)
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

RE: AcuXDBC Network Connection lost

Jump to solution

I do not believe there is a timeout type of setting in the AcuXDBC.cfg config file. Have you tried these variables in you AcuXDBC config file:

VISION_LOGGING_FILE

VISION_LOGGING_LEVEL

These may help you see the values that the query is working.

Also, we have seen an error similar to the one you are experiencing, but the cause was due to invalid data

In you AcuXDBC config file what setting are you using for invalid data

invalid_numeric_data    error

# invalid_numeric_data  truncate

# invalid_numeric_data  zero

To correct the issue, change the default value to truncate or zero and it should

not generate an error.

View solution in original post

0 Likes
4 Replies
Micro Focus Expert
Micro Focus Expert

RE: AcuXDBC Network Connection lost

Jump to solution

I do not believe there is a timeout type of setting in the AcuXDBC.cfg config file. Have you tried these variables in you AcuXDBC config file:

VISION_LOGGING_FILE

VISION_LOGGING_LEVEL

These may help you see the values that the query is working.

Also, we have seen an error similar to the one you are experiencing, but the cause was due to invalid data

In you AcuXDBC config file what setting are you using for invalid data

invalid_numeric_data    error

# invalid_numeric_data  truncate

# invalid_numeric_data  zero

To correct the issue, change the default value to truncate or zero and it should

not generate an error.

View solution in original post

0 Likes
Daniel7 Absent Member.
Absent Member.

RE: AcuXDBC Network Connection lost

Jump to solution

No, it didn't run. I changed my "acuxdbc.cfg" file like following:

#---------------GENERAL SETUP OPTIONS-----------------------

dictsource      /caesar/acuxdbc/syscat

file_prefix     ;/caesar/acuxdbc/data;/caesar/kundendaten/daten_fit/tiaakt;/cae

#  Specify your data file extensions; leave blank if no

#  extensions exist.

#file_suffix

#-------------------ADVANCED OPTION SETUP-------------------

file_case Upper

invalid_numeric_data    zero

read_only               yes

null_alpha_read null

null_alpha_write        spaces

null_numeric_read       0

null_numeric_write      0

julian_base_date        19000101

#-------------------VISION OPTION SETUP---------------------

max_files               32

max_locks               32

locks_per_file          10

v_buffers               32

null_alpha_read null

null_alpha_write        spaces

null_numeric_read       0

null_numeric_write      0

julian_base_date        19000101

#-------------------VISION OPTION SETUP---------------------

max_files               32

max_locks               32

locks_per_file          10

v_buffers               32

# aus cblconfig_env

       MAX-FILES       511

       LOCKS-PER-FILE  200

       MAX-LOCKS       1023

#-----TRANSACTION PROCESSING SETUP OPTIONS------------------

#transaction_processing Off

logging                 off

#log_encrypt            off

#log_device             off

log_file                /caesar/acuxdbc/log/transaction.log

# aus cblconfig_env

       MAX-FILES       511

       LOCKS-PER-FILE  200

       MAX-LOCKS       1023

#-----TRANSACTION PROCESSING SETUP OPTIONS------------------

#transaction_processing Off

logging                 off

#log_encrypt            off

#log_device             off

log_file                /caesar/acuxdbc/log/transaction.log

#temp_dir               .

#log_buffer_size        512

#---------------ACUSERVER SETUP OPTIONS---------------------

#acu_client_password

acuserver_port          20222

#security_method        none

#default_map_file

#---------------------Multi-company options-----------------

#  For multi-company handling, you can specify the value of any

#  wildcards that you used when creating the table in your

log_file                /caesar/acuxdbc/log/transaction.log

#temp_dir               .

#log_buffer_size        512

#---------------ACUSERVER SETUP OPTIONS---------------------

#acu_client_password

acuserver_port          20222

#security_method        none

#default_map_file

#---------------------Multi-company options-----------------

#  For multi-company handling, you can specify the value of any

#  wildcards that you used when creating the table in your

#  system catalog by noting the values here.

filename_wildcard XXXX=9200;$$=07;ST=ST

#---------------LOGGING SETUP OPTIONS-----------------------

vision_logging_file     /caesar/acuxdbc/log/vision.log

vision_logging_level    0

debug_logfile           /caesar/acuxdbc/log/debug.log

debug_loglevel          0

This is my "net.ini" in ".../acuxdbc/lib" directory:

key_connect     1234

hostenv0

packetsize      8192

read_timeout    0

write_timeout   0

return_errno    no

If I changed my Parameter files like up described, I detected no improvement adverse the older situation yesterday. Timeout is the same like yesterday.

0 Likes
Daniel7 Absent Member.
Absent Member.

RE: AcuXDBC Network Connection lost

Jump to solution

I follow this subject after my vacancy. Now I have got new examples of SQL statements which run or do not run, please look:

SELECT "CB1F"."CB1_XXSART" FROM "PUBLIC"."CB1F" "CB1F"

--> run

SELECT DISTINCT "CB1F"."CB1_XXSART" FROM "PUBLIC"."CB1F" "CB1F"

-> do not run!

I've got message "Network Connection lost" if I use DISTICT in my query. It seems there is a timeout anywhere, but where it is?

I switched both variables "vision_logging_level" and "debug_logging_level" from 0 to 9 resp. 1, vision.log was not written, debug.log was written but exceeds 2 GB borderline, that my client application hang out.

How can I avoid network connection lost and where can I take parameters to change timeout? I am sure, there are parameters anywhere to do it.

0 Likes
Micro Focus Expert
Micro Focus Expert

RE: AcuXDBC Network Connection lost

Jump to solution

If you run the DISTINCT query on the server where the data resides, does it provide a result? Since setting the "debug_logging_level" to 9  provided too large of a file, try setting it to 7 or as high as possible and still get a usable size log file. I do not think there is a time out built into the AcuXDBC, so this Network error message is coming from something else.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.