Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
tburlington Absent Member.
Absent Member.
466 views

C$system on windows 2012 R2

 We are running 10.2 64 bit.

We have a routine that uses the c@system command and we issue a "del" command and it does not work.

It returns and exit code of 0 but the file is still there.  We also issue an "ren" command afterward.

This routine works just fine on 10.264 bit on server 2008.

Tags (2)
0 Likes
4 Replies
DougP Outstanding Contributor.
Outstanding Contributor.

RE: C$system on windows 2012 R2

Hi Thomas,
I found one other report of C$SYSTEM failing on Windows Server 2012 and working on Windows Server 2008. That was a few years ago and was version 9.2.4. In that case the C$SYSTEM call was launching a batch file and there was a network share involved. Is the target of the delete command located on a network share, or local on the server?
-Doug
0 Likes
tburlington Absent Member.
Absent Member.

RE: C$system on windows 2012 R2

Doug, thank you. It is on a network share on AWS. We have successfully used the c$delete command and works fine. We just have to change all of our conversions.
0 Likes
JimmyBoy Trusted Contributor.
Trusted Contributor.

Re: C$system on windows 2012 R2

Sorry Guys, cant find where to create a new post !!!! infuriating...

 

I have server 2012 issue "OPEN EXTEND" is overwriting the file intermittently.

 

AcuCobol version 9.2.0

 

Everyone is happily appending ... then suddenly its all gone and starting from scratch

0 Likes
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: C$system on windows 2012 R2

Good morning, @JimmyBoy 

We have no evidence of such an issue in ACUCOBOL-GT, either in 9.2 or in successive releases.
Can you activate the runtime tracing facility , record a case where the issue occurs and then report this trace file to SupportLine?

Please add these variable to your runtime configuration file before executing your tests:

FILE_TRACE 9
FILE_TRACE_FLUSH 1
FILE_TRACE_TIMESTAMP 1

Looking forward for these logs.
Best Regards.

P.S.: In order to create a new post, have you tried typing your request in the Entry-Field "Ask a Question or Start a Discussion" and clicking on the "Continue" blue button?

You have to be in the "Extend and AcuCOBOL - Forum" page:
(https://community.microfocus.com/t5/Extend-and-AcuCOBOL-Forum/bd-p/forumid-20)

----------------------------
Claudio Contardi
Product Support Engineer, Senior
Micro Focus
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.