Highlighted
Absent Member.
Absent Member.
532 views

DOTNET to ACUCOBOL

[Migrated content. Thread originally posted on 29 August 2011]

Hi
We have a web site created using ASP MVC3 from where we call our Acucobol applications using Interop.AcuGTObjects.
This works well on 32-bit systems.
We have now installed Visual Studio 2010, ASP MVC3 and Acucobol on a new machine, using Windows 7 64bit. When starting out, we get:
Server Error in '/SveaWeb_deploy' Application.
Could not load file or assembly 'Interop.AcuGTObjects' or one of its dependencies. An attempt was made to load a program with an incorrect format.

Do we have a clash here between 32 and 64 bit?
Or have we not registered everything correctly?

Anyone doing something similar?

Robert
0 Likes
2 Replies
Highlighted
New Member.

RE: DOTNET to ACUCOBOL

You can't load 32-bit DLLs in a 64-bit process. One option is setting the website to run in 32-bit mode.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: DOTNET to ACUCOBOL

That was the answer!!
Also some work getting the Acucobol Automation Server registered and with the right permissions, then everything worked fine.
Thank you GMCfourX4.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.