Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
RubenTenerife
New Member.
971 views

Font troubles

Hi,

I've got some issues using w$font, in Windows:

First of all I accept the standard Font:

ACCEPT VP-MAIN-FONT FROM STANDARD OBJECT "DEFAULT-FONT"

The Font is usually 'MS Sans Serif'

- When I set this font to  14 size, the font is always bold

- I can not define a 9, 11, 13 size, w$font returns a error, but from another application this sizes are available

Can I do something to solve this?

Thanks!

0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

RE: Font troubles

The accept statement and call to w$font are two different things. I'm going to guess that you are using the fonts.def copybook, have you initialized  WFONT-DATA?  Try our showfont.cbl example program.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.