Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
JaapV Super Contributor.
Super Contributor.
1132 views

Program's running on Windows10, how to let it run on Red Hat enterprise server 7.5

Linux/Unix is almost new for me. Which is the best TERM to use in combination running ACUGT 9.2.4 and/or 10.2. Is it vt220?

When yes, how has for me a A_TERMCAP including mouse and colors? The a_termcap MF provided is from 2006.

Tags (2)
0 Likes
8 Replies
Micro Focus Expert
Micro Focus Expert

RE: Program's running on Windows10, how to let it run on Red Hat enterprise server 7.5

In the Acu install, you'll see a /etc/a_termcap file. This file has a number of different termcap entries. Or there maybe some termcap file that you would like to use. You can set TERM, or A_TERM if you prefer to use a certain TERM and want a different terminal setting for Acu programs. A_TERMCAP can be set to the termcap file of your choosing or you can set it to the
etc/a_termcap that is installed when installing Acu.
0 Likes
JaapV Super Contributor.
Super Contributor.

RE: Program's running on Windows10, how to let it run on Red Hat enterprise server 7.5

I have seen this and go it:

TERM=vt220
export TERM
A_TERMCAP=/opt/acucobol/924/etc/a_termcap
export A_TERMCAP
configfile=/BS/PROG/ETC/Uniconfi
export configfile
runcbl -dle go4it.log -c $configfile START.acu                     

But a file from 2006 still has everthing into for 2018?   

0 Likes
Micro Focus Expert
Micro Focus Expert

RE: Program's running on Windows10, how to let it run on Red Hat enterprise server 7.5

[quote]

But a file from 2006 still has everthing into for 2018?

[/quote]

The VT220 shipped in 1983. It was superseded by the VT300 series in 1987. It didn't change between 2006 and now.

Now, it's unlikely you're using an actual VT220; you're almost certainly using an emulator. But if the emulator added features to its VT220 mode that aren't in a real VT220, then it's not really emulating a VT220.

More generally, Linux/UNIX terminal emulation is a crapshoot. Termcap (and its successor terminfo) tell applications what control sequences to send to the output device to achieve certain effects. That works provided:

  1. The output device actually supports those effects.
  2. The user has correctly identified the output device to the application (TERM environment variable).
  3. The termcap/terminfo information for that device type is correct.
  4. The application, or whatever is processing its output (COBOL runtime, curses, etc), handles the control sequences correctly.
  5. Nothing else (line discipline, etc) gets in the way.

Your best bet, frankly, is to experiment with different settings and see what works for you, for a particular application running under a particular terminal emulator with a particular configuration. Other users, with other emulation software or settings, may well have a different experience.

0 Likes
JaapV Super Contributor.
Super Contributor.

RE: Program's running on Windows10, how to let it run on Red Hat enterprise server 7.5

Thank's Michael.
I use Putty from my desktop to login on de Red Hat laptop. In config of Putty, keyboard VT100+ and in de runscript TERM=vt100.

For every one. Who has a cblconfi in combination with the above writing?
And who can export his PuTTy Configuration and send to me without important values of cause.
0 Likes
GeorgeK Absent Member.
Absent Member.

RE: Program's running on Windows10, how to let it run on Red Hat enterprise server 7.5

ok, but if you get Facetwin install it on the server then the Windows machine you can run in GUI mode rather than TUI mode. You just point it at the ...32.exe in facetwin. Probably a ...64.exe by now too.
0 Likes
JaapV Super Contributor.
Super Contributor.

RE: Program's running on Windows10, how to let it run on Red Hat enterprise server 7.5

For a great part it is working now. Home, Delete, End, Page UP, Page Down and Insert. I use TERM=linux and login on my desktop with SuperPuTTY(KEYBOARD Linux). With command showkey -s --scankeys i found the values for the Shft/Fx keys for in the a_termcap. Still there are a few issues. First the Crtl/Fx keys give the same value as the Fx keys.  So, how knows the solution for Ctrl/Fx? Second, i use DISPLAY BOX LINE xx POSITION xx SIZE xx LINES xx COLOR xx. On Windows the rectangle is displayed, but on Red Hat it is; above line: lqqqqqqqqqqqqqqqqqqqqqqqqqqk, below line: mqqqqqqqqqqqqqqqqj. Vertical it is xxxxxx. How it is solved?

0 Likes
Chuck Edgin Absent Member.
Absent Member.

RE: Program's running on Windows10, how to let it run on Red Hat enterprise server 7.5

Hi Jaap

PuTTY (and its derivatives) attempts to emulate the X Windows "xterm" program, so the xterm entry in a_termcap would be your best starting point. I haven't played with this in several years, but I have a modified a_termcap in which I've included entries that extend the xterm entry to use actual line drawing characters (versus using hyphens, plus signs, etc); to allow use of the mouse (for activating buttons, menu items, etc.) and even to add some colors.

Find the "xterm" entry (it will start with: vs|dtterm|xterm|...) in your existing "stock" a_termcap file, and add the following stanzas just before it:

cxterm-ldm|Modified color xterm, incl line drwg and mouse support:\
    :B1=\E[40m:B2=\E[44m:B3=\E[42m:B4=\E[46m:\
    :B5=\E[41m:B6=\E[45m:B7=\E[43m:B8=\E[47m:\
    :C1=\E[30m:C2=\E[34m:C3=\E[32m:C4=\E[36m:\
    :C5=\E[31m:C6=\E[35m:C7=\E[33m:C8=\E[37m:\
    :tc=xterm-ldm:
    
xterm-ldm|Modified xterm, incl line drwg and mouse support:\
    :is=\E7\E[?47h\E[r\E[m\E[2J\E[H\E[?7h\E[?1;3;4;6l\E[?1h\E=\E[?1000h:\
    :DI=\E[2J\E[?47l\E8\E[?1000l:km=\E[M:\
    :GO=\E(0:GF=\E(B:GM=qxlkmjvtwun:\
    :tc=xterm:

 

You may notice that the first one (cxterm-ldm) references the second one (xterm-ldm) using the :tc= setting. Then xterm-ldm in turn references the existing xterm entry. You can experiment with each one by setting A_TERM to the one you want to try:

export A_TERM=cxterm-ldm 
export A_TERM=xterm-ldm 
export A_TERM=xterm

(you can use the TERM variable instead of A_TERM, but A_TERM will take precedence if it's set)

JaapV Super Contributor.
Super Contributor.

RE: Program's running on Windows10, how to let it run on Red Hat enterprise server 7.5

Hi Chuck,

I did not worked with Unix/Linux, so my knowledge is almost null. I installed Red Hat Enterprise Linux 7.5

The result is not yet what i expected, but it can be everything i supose.  

Let we start with the PuTTy configuration Terminal: which KEYBOARD and which other settings i need?

I use SuperPuTTy to set up the connection.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.