Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
prolinkdata_gr Trusted Contributor.
Trusted Contributor.
868 views

acubench 10.1.1 report generation issue

Hi all,

 

we created a project form scratch, in a new workspace, on acubench 10.1.1 (Windows 10) and we are facing the following problem:

Project has a single program with one form. When we add a new empty report "Report1", option "Generate Source" completes with no errors. When we add a single report entry field, even with no value, option "Generate Source" hangs at 39% and after few seconds acubench crashes. Same project opened from acubench 10.0.1 works fine.

We noticed that at the /Report folder, Report1.rpt file exists but is empty.

Are we missing something in acubench configuration?

Thanks in advance

0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

RE: acubench 10.1.1 report generation issue

That is odd. I just tried it with my 10.1.1 and I do not get this issue.
0 Likes
GeorgeK Absent Member.
Absent Member.

RE: acubench 10.1.1 report generation issue

May be setup issue. Need to double check all their paths.
0 Likes
GeorgeK Absent Member.
Absent Member.

RE: acubench 10.1.1 report generation issue

Or possibly 10.1.1 had install issue.
0 Likes
prolinkdata_gr Trusted Contributor.
Trusted Contributor.

RE: acubench 10.1.1 report generation issue

FYI

We opened a ticket for this issue and Microfocus support suggested that we try 10.2.0 because "10.1.1 did suffer with some code generation errors that were fixed in 10.2".
"Generate" and "compile" the same project with 10.2.0, succeeded.
0 Likes
GeorgeK Absent Member.
Absent Member.

RE: acubench 10.1.1 report generation issue

I'm glad you were able to get it working. Oddly, when I was at Ocuco as recently as 4/11/2018, we were compiling back to Acucobol 3.2 compatibility. Two of the Acucobol developers had Acucobol 5.1 on their system but I had Acucobol 8 on my system. I had working versions of our Labzilla software compiled in Acubobol 6.0 and Acubobol 7.0 compatibility modes and I had working compile of Acubobol 8 on my system. I tested all versions, but they were unwilling to upgrade. Dan has no knowledge of COBOL at all.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.