Highlighted
Absent Member.
Absent Member.
772 views

[archive] AcuConnect

[Migrated content. Thread originally posted on 24 August 2004]

Guys,

You will probably know this or have encountered this already, but I have a program which imports data from another application via a flat file.

This import program really needs to show the user whats happening, i.e. Current customer being imported, and some counters to show if its a new account, existing account and total records imported.

This is fine when I run it on my own machine locally, but when I run it in thin client mode, it doesn't display anything until its finished?

Is there some runtime/thin client flag which I need to switch on?

Many thanks,

Shaun
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

RE: [archive] AcuConnect

The runtime is minimizing traffic between the server and the remote so it won't send ALL the paint messages to the remote. I am not aware of any RT flags but happy to be corrected.

Try using c$sleep 0.1 between each display. It does slow down the process but may do what you desire.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] AcuConnect

You might want to check out 8.7.2 Tuning system performance in the Acuconnect documentation.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] AcuConnect

Gisle,

I guess you're heading in the direction of the TC-CONTROL-SYNC-LEVEL flag?

It does'nt work, not did the idea of the sleep 0.1.

However via support a developer has pointed out that whats happening is expected normal behaviour.

Here's an idea as to whats happening in the first place.

User picks "Import Sun Accounts"

Up pops a nice tidy screen with Customer Code, name & 3 counter fields, together with 2 push buttons(one to exit and on to go)

When the user clicks Import, then I have the blank screen until it imports all the accounts and then it says "OK that 1996" account added or amended etc.

This click is an "EVENT-CMD-CLICKED" and apparently here lies the problem with thin client.

However I've been instructed to make this an "EXCEPTION-CMD-CLICKED" and it now works like its meant to.


Shaun
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.