Highlighted
Absent Member.
Absent Member.
398 views

[archive] AcuXML Cannot Read XML file created by AcuXML

[Migrated content. Thread originally posted on 10 October 2009]

I've been experimenting with creating XML files using the AcuXML interface. I created a simple FD with 3 fields, set the Filename_Host XML and ran the program. The created file looks fine.

Next, I tried to read the file just created using the same FD. The read of the files aborts with an error 9D05,18, indicating an invalid encoding.

Looking at the generated XML file, the first line is:



If I manually edit the XML file and change "ASCII" to "US-ASCII", "UTF-8" or "ISO-8859-1", I can read the file correctly.

I have tried using the AXML_ENCODING to change this, but it seems to have no effect. I have set it in the runtime configuration, set it in the program with Set Environment and none of these succeeded in getting the encoding to change. It always remains ASCII.

I'm not sure if AXML_ENCODING is being overridden somewhere or if this is a bug. Other AXML configuration entries work as documented.

Has anyone else had an issue with this?
0 Likes
1 Reply
Highlighted
Absent Member.
Absent Member.

RE: [archive] AcuXML Cannot Read XML file created by AcuXML

I would suggest you report this to Technical support.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.