Highlighted
Absent Member.
Absent Member.
175 views

[archive] C$SYSTEM Failure on 6.2 thin with XP Client

[Migrated content. Thread originally posted on 06 July 2005]

Hello everyone,
I set up a thin client system (ver.6.2.0.1) on a Linux Server:
I have some cobol programs that fires a C$SYSTEM to launch an external .exe program (this program only send a certain file to the com port): the library function have the csys-desktop + csys-shell + csys-hidden attributes added to the call flags.
On Win98 clients it works fine but on a WinXp Pro client the thin
freezes up and the .exe isn't executed until the thin process is killed on the client.
Has someone meet the same problem?
Any idea will be appreciated, thank in advance, Giovanni
0 Likes
1 Reply
Highlighted
Absent Member.
Absent Member.

RE: [archive] C$SYSTEM Failure on 6.2 thin with XP Client

Hello everyone, I've found a workaround:
adding the csys-async to the flags the C$SYSTEM call on the XP Client again works fine. Now I wonder why a previous call to a .bat command worked without the async flag and the .exe don't! Any idea?
Bye Giovanni
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.