Highlighted
Absent Member.
Absent Member.
307 views

[archive] Delete key - Linux

[Migrated content. Thread originally posted on 31 August 2009]

We are having problems in Linux with the delete key. We have a set of programs that we have to run in text mode using telnet. We have a problem setting the delete key to create an exception in the program. We have set enviornment variable KEYSTROKE Exeception=61 KX but it continues to work as a backspace key. Has anyone had this problem?

Thanks,
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

RE: [archive] Delete key - Linux

Hi,

We use Linux exclusively, so hopefully I can help out. Can you tell me what terminal type you are using? Is this terminal type defined in the /etc/a_termcap file?

At a linux prompt, can you enter the command "stty" and post the output for me?

Also, which flavour of Linux are you using?

Cheers,

Ian
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] Delete key - Linux

Thanks for the reply, we are using RedHat v5 and CentOS v5, Acucobol v8.
I have attached a file that has the stty, env, cobol config, bash profile and a_termcap that we use. Thanks for any help.

Note the delete key works as the backspace when in a field which is what we want it to do except in specific situations. The area we want it to work different is when we want to delete a line. This works in our old SCO Unix systems. To get it to work we are setting environment variable in the program that looks like this:
move 'KEYSTROKE" to env-name
move "Exception=61 KX" to env-value
set environment env-name to env-value.

Thanks again.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] Delete key - Linux

Using vi, or vim, at the end of your /etc/profile file, add this line:-stty erase ^HTo get the Control-H using vi, first type Control-V and then Control-H. The Control-V tells vi/vim to accept the following control characters as data, rather than control-codes.

Since you're using telnet on RHEL, I wonder if you've also hit the xinetd limit of 50 users. To address this, edit the file /etc/xinetd.conf and increase the "instances" value to whatever you need it to be. The default is 50, but it applies to all services initiated by xinetd, not just telnet. This can include rsync, rsh, rexec, tftp, and others (look in /etc/xinetd.d for a full list).
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.