Highlighted
Absent Member.
Absent Member.
463 views

[archive] Leading Spaces - Report Label

[Migrated content. Thread originally posted on 01 May 2008]

Hello, again
I am moving a value to a Report Label in a graphical report created in Report Composer. The value contains leading spaces, but when the report is displayed, the leading spaces have been stripped out. How can I keep the leading spaces in?

Thanks
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

RE: [archive] Leading Spaces - Report Label

Are you creating an HTML report? If you, you should insert   instead of spaces.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] Leading Spaces - Report Label

Thanks, blacky
How would the coding look for &nbsp?
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] Leading Spaces - Report Label

I haven't used the report composer, but I know a little HTML. If you put multiple blanks into an HTML file they are ignored (only 1 is used). To have multiple space characters you need to tell the browser to display them by using " " instead of white space in your report. So for every space you want to insert, you have to actually insert 6 characters -  

Ian
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.