Highlighted
Absent Member.
Absent Member.
282 views

[archive] MSMAPI32 Mail Not Happenin'

[Migrated content. Thread originally posted on 22 August 2007]

:confused: Attached are the source code (copied from this forum), trace file, and object code... This program does not produce email from an Outlook or Outlook Express mail client. I'm running on Win XP with Acucobol v7.2.

Any help will be GREATLY appreciated!
0 Likes
4 Replies
Highlighted
Absent Member.
Absent Member.

RE: [archive] MSMAPI32 Mail Not Happenin'

Well, you don't provide much information. First question is: Do you have Outlook or Outlook Express as the default email client on the machine you use.
Second question is: Do the preferred email client have an email account set up?
Third question is: Can you send an email from that email client without problems?
A suggestion: This source is not the latest one that is produced to be as email client neutral as possible. You find that code posted here http://www.acucorp.com/support/supported/customer_forum/showthread.php?t=1091 Can you try with that code?
Remember to update the code.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] MSMAPI32 Mail Not Happenin'

1. I've tested on two different systems, one with Win XP and Outlook mail client and the other has Outlook Express as the default mail client on a 2003 server.
2. Yes.
3. Yes.

Were you able to run the object code I provided?

I'll try the code you refer to and hopefully discover what it is that I'm obviously missing.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] MSMAPI32 Mail Not Happenin'

I am doing this successfully both with Outlook and Outlook Express on various windows platforms (including Vista). I downloaded that same source code to start with and I don't remember making hardly any modifications to it - other than adding coding to send attachments. I do know this coding did not work for me with Outlook. I was not able to get the MSMAPI control to work with Outlook. I had to use the actual Outlook dll and write seperate coding for users with Outlook.

Do you get an error when you try to execute the program? Knowing what error you are getting (if any) might be helpful. If you don't get any errors, have you checked to see if the messages are showing up in the Outbox, but not being sent?
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] MSMAPI32 Mail Not Happenin'

😄 rebekah and gforseth -- thank you both so much for replying to my posts. After starting over with the sample suggested by gforseth (and a few minor tweaks) I was able to send email with Outlook, Outlook Express on XP, 2003, and Vista. Thanks again!

p.s. rebekah - I did not receive any error messages and there were no messages in the outbox... this is what was driving me so crazy.. no clues! Thank you for your input and help!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.