Highlighted
Absent Member.
Absent Member.
494 views

[archive] -p spooler direct

[Migrated content. Thread originally posted on 11 May 2009]

Hello all,

We are printing in some cases using -p spooler direct, but when the printer finish we see that some special characters don't appear correctly: ?, ?, ? for example are transformed into another character. In the printer, a technician says us that the map of characters is correctly configured.

Anyone with the same problem or with experience in it?

Thanks afterwards
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

RE: [archive] -p spooler direct

Do you send plain text, or do you send escape sequences for formatting as well?
If you do send escape sequences, either your sequence is incorrect or incomplete, or the current mode of the printer does not support what you send. If you for instance have escape sequences programmed for PCL5 and the printer is in PCL4 mode, some features may not be supported.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] -p spooler direct

Hello Gforseth,

We are sending plain text to the printer
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] -p spooler direct

In which case I am pretty sure the printer's encoding character set is not what you expect it to be. Most printers show up using codepage 437 (US extended ASCII).

Do you know what codepage your printer is set to?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.