Highlighted
Absent Member.
Absent Member.
1398 views

[archive] trouble with xml2fd

[Migrated content. Thread originally posted on 23 March 2010]

I open AcuBench and choose Tools -> xml2fd.

Then I select the file that I have attached.

I receive a "Unabe to open named file" error.

:confused:
0 Likes
6 Replies
Highlighted
Absent Member.
Absent Member.

RE: [archive] trouble with xml2fd

change the first line to this:

0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] trouble with xml2fd

Thanks for the suggestion.

However, I still get the error.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] trouble with xml2fd

hmm, not sure, once I changed the tup line to not have the utf encoding, xml2fd work for me. Are you specifying an output directory that is different from where the test.txt resides?
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] trouble with xml2fd

see attached .sl and .fd
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] trouble with xml2fd

Using the provided XML file (test.txt) I modified the first line to be:



Then opened AcuBench, chose Tools\Xml2FD and clicked [Start] and it procossed the file and created test.fd and test.fl files. The tool did note that it had to guess on some data items:

.\test.fd:5: Guessed on length of data item
.\test.fd:7: Guessed on length of data item
.\test.fd:9: Guessed on length of data item
.\test.fd:11: Guessed on length of data item
.\test.fd:13: Guessed on length of data item
.\test.fd:15: Guessed on length of data item

The test.fd file looks like this:

* .\test.fd - Generated by xml2fd from E:\test\xml_files\test.txt on 2010/03/23
fd CATALOG.
01 CD.
03 TITLE pic x(24).
03 ARTIST pic x(17).
03 COUNTRY pic x(6).
03 COMPANY pic x(14).
03 PRICE pic 9(2).9(2).
03 YEAR pic 9(4).

and the test.sl file looks like this:

* .\test.sl - Generated by xml2fd from E:\test\xml_files\test.txt on 2010/03/23
select CATALOG
assign to disk "test"
binary sequential
status is CATALOG-status.
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: [archive] trouble with xml2fd

I had the xml file, test.txt, in another directory than the fd folder.

Thanks for the help.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.