Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
sfi_dev Absent Member.
Absent Member.
4092 views

wrun32.exe takes a long time to load

Jump to solution

Hi there,

I ran this past MicroFocus a while ago but did not get very far so thought I would open it up to the community.

I have noticed that on some servers the wrun32.exe is very slow to start.  We have a client running on windows 2008 server 64-bit with the 32-bit Acu4gl extend 9.01 runtime.  The runtime resides on a SAN physical drive and when RDPing into the server and double cliking on the wrun32.exe it can take up to 60 seconds before getting the cbl.out message of no parameters appears.  You can see the wrun32.exe building in memory size very slowly until it is launched.  Even if I put the runtime on the local c drive the performance is very slow to start up.  Once you are in the application the performance is fine.

Has anyone else experienced this.  The server does not have internet access.  Interesting point is that if the wrun32.exe is executed via Web Thin Client it starts really quickly which makes it even more perplexing.

Other servers for other clients and in-house have mixed results also - some take a long time and others are really quick.  But 60 seconds seems execessive especially when directly starting the application on the server.

Any advice or suggestions would be much appreciated.  Our client is getting really annoyed.

Thanks in advance.

sfi_dev

0 Likes
1 Solution

Accepted Solutions
sfi_dev Absent Member.
Absent Member.

RE: wrun32.exe takes a long time to load

Jump to solution

Incase anyone else has the same issue in the future - The login issue appears to be resolved.  After launching wrun32.exe it looks like it was attempting to connect to the Verisign website.  The service account was not set to go through the proxy, so the exe just timed out when connecting to Verisign.  I’ve enabled the proxy.  The wrun32.exe start times have improved considerably.

View solution in original post

0 Likes
1 Reply
sfi_dev Absent Member.
Absent Member.

RE: wrun32.exe takes a long time to load

Jump to solution

Incase anyone else has the same issue in the future - The login issue appears to be resolved.  After launching wrun32.exe it looks like it was attempting to connect to the Verisign website.  The service account was not set to go through the proxy, so the exe just timed out when connecting to Verisign.  I’ve enabled the proxy.  The wrun32.exe start times have improved considerably.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.