Highlighted
Absent Member.
Absent Member.
4701 views

xODBC Configuration with AcuServer

Jump to solution

I have trouble configuring XODBC to view vision files via-AcuServer,

Someone can tell me how to configure FILE-PREFIX variabile in AcuXdbc.cfg correctly?

Thanks in advance...

0 Likes
1 Solution

Accepted Solutions
Highlighted
Outstanding Contributor.
Outstanding Contributor.

RE: xODBC Configuration with AcuServer

Jump to solution

In the acuxdbc configuration file FILE-PREFIX is used the same as with the Runtime with two exceptions.  You must begin with the separator character and you must use forward slashes or double back slashes.  So you will have something like:  

file-prefix ;@servername:/path/to/files

If you are not running AcuServer on the default port then you must add:

ACUSERVER-PORT nnnnn

View solution in original post

0 Likes
9 Replies
Highlighted
Outstanding Contributor.
Outstanding Contributor.

RE: xODBC Configuration with AcuServer

Jump to solution

In the acuxdbc configuration file FILE-PREFIX is used the same as with the Runtime with two exceptions.  You must begin with the separator character and you must use forward slashes or double back slashes.  So you will have something like:  

file-prefix ;@servername:/path/to/files

If you are not running AcuServer on the default port then you must add:

ACUSERVER-PORT nnnnn

View solution in original post

0 Likes
Highlighted
Absent Member.
Absent Member.

RE: xODBC Configuration with AcuServer

Jump to solution

Thank Doug,

but I dont understand why the problem was not solved....

when I reference vision file via simple network share

eg.   file-prefix ;n:\path\to\files

all is right

but when I specify the Acuserver-path it dont find vision-file.....

here some informations....

file acuXdbc_NUT.cfg:

.....

  file_prefix ";@server-e09:/home/zeronove/092p2/nut/euro09/az/f"

 file_suffix dat  

...

  acu_client_password none

 acuserver_port 6524

 security_method none

on the AcuAccess:

Client Machine Name  Client Username  Local Username   Password     Umask
-------------------- ---------------- ---------------- ------------ -----
*                                     zn2p3            <none>       000

the server is Alive and it works correctly in a wrun32-session

but when I try to connect to the table the vision file is not found.....

C:\Users\roberto>asql -c acuxdbc_NUT.cfg
SQL (/? for help) ==> /d tartico
***** ERROR: VISION: File 'artico' does not exist

I tried to debug activating vision_debug mode......

vision_logging_file c:/tmp/xODBC.log
vision_logging_level 1

but I get a generic Error like this:


Any Ideas?

Thanks a Lot!!!! Smile

Tags (2)
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: xODBC Configuration with AcuServer

Jump to solution

Sorry, this is the Generic Error:

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: xODBC Configuration with AcuServer

Jump to solution

What version of Acu XDBC are you using and what version is your AcuServer? When you open the error log, is there anything there? Also, consider starting AcuServer with a trace .. acuserve -start -t3 -e acuserv.err and see if the server log shows something.

0 Likes
Highlighted
Absent Member.
Absent Member.

RE: xODBC Configuration with AcuServer

Jump to solution

AcuXDBC 9.01 and AcuServer 9.01

the error_log is empty

and nothing appears in the srv6524.log:

[root@SERVER-E09 acusrv]# cat srv6524.log

Started at 11314739

Tracing enabled:

 message calls

 file I/O calls

[root@SERVER-E09 acusrv]#

But when I run the standard wrun32 from the same workstation file log is correctly populated....

11364348 - PING request - client time: 11363812
 client data: 'testing socket vitality'
v_open: 204, '/home/zeronove/092p2/nut/euro09/az/f/tabel.dat', 196608, '0,0,0'. 0
Are we running as a different user: 0
Check access for file '/home/zeronove/092p2/nut/euro09/az/f/tabel.dat', (502, 503)
Directory '/home/zeronove/092p2/nut/euro09/az/f/.' has uid 502 and gid 502
Can create files in this directory
Directory '/home/zeronove/092p2/nut/euro09/az/f/./..' has uid 502 and gid 502
Directory '/home/zeronove/092p2/nut/euro09/az/f/./../..' has uid 502 and gid 502
Directory '/home/zeronove/092p2/nut/euro09/az/f/./../../..' has uid 502 and gid 502
Directory '/home/zeronove/092p2/nut/euro09/az/f/./../../../..' has uid 502 and gid 502
Directory '/home/zeronove/092p2/nut/euro09/az/f/./../../../../..' has uid 502 and gid 502
Directory '/home/zeronove/092p2/nut/euro09/az/f/./../../../../../..' has uid 0 and gid 0
Directory '/home/zeronove/092p2/nut/euro09/az/f/./../../../../../../..' has uid 0 and gid 0
Can search (READ/EXECUTE) all parent directories
Can create files in the directory
File '/home/zeronove/092p2/nut/euro09/az/f/tabel.dat' has uid 502 and gid 502
User access to file '/home/zeronove/092p2/nut/euro09/az/f/tabel.dat' is 0xf
Checking access for '/home/zeronove/092p2/nut/euro09/az/f/tabel.dat': 0xf, 196608
returned 239, 70, 70
adding client 'pc-roberto' user 'roberto' pid 10376 fid 239
  socket 204 file '/home/zeronove/092p2/nut/euro09/az/f/tabel.dat' type 1
Number of files increased to 6
v_info: 204, 239, -1 - returned '0000000070,0000000070,001'
v_info: 204, 239, 0 - returned '01,0,003,0000000000'
v_read: 204, 239, 0, 0x1 - >>>key 0 = '$$$'
read 70 bytes
v_close: 204, 239 - succeeded
removing client 'pc-roberto' user 'roberto' pid 10376 fid 239
Number of files decreased to 5


Thanks a lot for your support

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: xODBC Configuration with AcuServer

Jump to solution

Since there are no entries in the AcuServer log when trying Acu XDBC, it appears that Acu XDBC is not handing off it's query to AcuServer. I have two suggestions, start AcuServer on the default port 6523 and change the Acu XDBC configuration to use that port. Also, try the server IP address in the file_prefix instead of the server-name

0 Likes
Highlighted
Absent Member.
Absent Member.

RE: xODBC Configuration with AcuServer

Jump to solution

Shjerpe,

I tried with def port 6523 and IP address but the problem is the same..... Confused

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: xODBC Configuration with AcuServer

Jump to solution

Are your xfd files based locally or on the server?

Please try them locally. start acuserve .. acuserve -start -t 3 -le error-file do your query, kill acuserver, look at the error file .. there should be some entries showing the client connecting to the server.

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: xODBC Configuration with AcuServer

Jump to solution

for FILE_PREFIX - you use either double back slash, or single forward slash with file prefix. Since you've been using the single forward slash .. try the double black slash ";@server-e09:\\home\\zeronove\\092p2\\nut\\euro09\\az\\f"

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.