scheurer13 Absent Member.
Absent Member.
4889 views

NFR Admin could not communicate

Hi together,

what i'm doing wrong? I've installed the engine, agent and dsi-edir on my oes2sp2 (64bit) Server. All are running and the ports are open.
But the NFRAdmin from my WinPC says "Could not communicate with the engine".

Don't know where my mistake is...
0 Likes
4 Replies
scheurer13 Absent Member.
Absent Member.

Re: NFR Admin could not communicate

agentncp debug.log:
EngineInterface: UI authorization failed

engine debug.log:
ClientInterface: received authentication reques.
0 Likes
pch Absent Member.
Absent Member.

Re: NFR Admin could not communicate

Hi, sounds like the same problem in a previous thread.

The solution, for me, was this:

The issue is that the installation is failing to change the password
during the installation. An update is available and can be requested
from sending an email to filereporter"@"novell.com. For an immediate
workaround, you can manually force a password change on the NFRProxy
account by doing the following:

stop the service
cd /opt/novell/filereporter/dsi-edir

64Bit
LD_LIBRARY_PATH=./lib64 ./bin/nfrdsi-edird --force-proxy-reset
--username:admin.o --password:???? --default-server:xx.xx.xx.xx

Start the service. It should remain running!

Regards
Peter
0 Likes
nickyvermaak
New Member.

Re: NFR Admin could not communicate

I was privileged enough to work with some on the guys in the USA directly via email to have my issues resolved. Awesome team!

In my case I had to switch off/disable proxy settings on Internet Explorer. It sounds stupid, but it worked.

The product in a non-NSM and 64-bit environment is not 100% functional out of the box, but sure there is nothing a good service pack cannot fix. 😉
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NFR Admin could not communicate

Nicky,
There is a FAQ for Storage Manager that should work for File Reporter also.

http://www.storagemanagersupport.com/nsm20/support/troubleshooting/nsmadmin-internetproxies.php

Basically you need to create a file with the same name as the executable
with .config concatenated onto the end of it. (NFRAdmin.exe.config) This
problem effects all .NET applications where Internet Explorer of the
local system has a proxy configurations. These proxy configurations are
honored by .NET, but not the "bypasses". This file will act as your
proxy bypass for this .NET application.

The file needs to have the following contents.

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<system.net>
<defaultProxy>
<bypasslist>
<add address="[a-zA-Z0-9]+\.novell\.com" />
<add address="192\.168\.100\..*" />
</bypasslist>
</defaultProxy>
</system.net>
</configuration>

You will need change out the novell with your domain, and the
192.168.100 section with the ip addresses appropriate to your network.

Hope this helps,
NFR Development

NickyVermaak wrote:
> I was privileged enough to work with some on the guys in the USA
> directly via email to have my issues resolved. Awesome team!
>
> In my case I had to switch off/disable proxy settings on Internet
> Explorer. It sounds stupid, but it worked.
>
> The product in a non-NSM and 64-bit environment is not 100% functional
> out of the box, but sure there is nothing a good service pack cannot
> fix. 😉
>
>

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.