seba4
New Member.
769 views

Filr 3.4.3 to 4.0 upgrade

Hi today i was trying to upgrade filr 3.4.3 to 4.x but i had some problems with upgrade.

More or less problem was with migration from mysql to postgresql.

I was following this documentation:
https://www.microfocus.com/documentation/filr/filr-4/filr-inst/t43dt993zq1c.html

Everything went well until i came to this point:
When the appliance displays the final screen in the console window, open your management browser and log in to the appliance on port 9443 as the vaadmin user.

Here i had some errors/missing icons:

  1. phpPGAdmin icon is missing in UI
  2. Filr - Configuration returned error. PostgreSQL problem.



  3. From what i have noticed is that Postgres is trying to use ROOT user which doesn't exist. I had to modify /filrinstall/installer.xml and change username to POSTGRES

    [PHP]
    <Config id="Installed" type="PostgreSql">
    <Resource driverClassName="org.postgresql.Driver" for="icecore" password="SOME_PASSWORD" url="jdbc:postgresql://localhost:5432/filr?charSet=UTF-8" username="postgres"/>
    </Config>
    </Database>
    [/PHP]



    Second problem was that even that authentication was correct in console, i didn't get it to work from filr script so i have changed postgres authentication method from MD5 to Trust.

    File: /vastorage/postgres/conf/vabase-pg_hba.conf
    [PHP]
    local all all trust
    [/PHP]

    And the third problem was that database filr was missing. I was first looking if some script includes creation of filr database but i couldn't find it so i have created it on my own.
    [PHP]
    psql -U postgres -c "create database filr;"
    [/PHP]

    After this upgrade finished.

    Upgrade could be restarted through https://FILR_IP:9443/filrconfig
    After you get an error you click "Finish" and filr retries upgrade.


    After another check i have noticed that if upgrade is succesfull phpPGAdmin icon is there, but connecting to https://FILR_IP:8443/ssf/a/ returns an error so i need to debug more.

    ERROR:

    [PHP]
    HTTP Status 500 – Internal Server Error
    Type Exception Report

    Description The server encountered an unexpected condition that prevented it from fulfilling the request.

    Exception

    java.lang.NullPointerException
    org.hibernate.cache.impl.bridge.RegionFactoryCacheProviderBridge.nextTimestamp(RegionFactoryCacheProviderBridge.java:93)
    org.hibernate.impl.SessionFactoryImpl.openSession(SessionFactoryImpl.java:637)
    org.hibernate.impl.SessionFactoryImpl.openSession(SessionFactoryImpl.java:646)
    org.springframework.orm.hibernate3.SessionFactoryUtils.doGetSession(SessionFactoryUtils.java:321)
    org.springframework.orm.hibernate3.SessionFactoryUtils.getSession(SessionFactoryUtils.java:202)
    org.kablink.teaming.util.SessionUtil.sessionStartup(SessionUtil.java:63)
    org.kablink.teaming.webdav.servlet.filter.HibernateSessionSetupFilter.setupHibernateSession(HibernateSessionSetupFilter.java:92)
    org.kablink.teaming.webdav.servlet.filter.HibernateSessionSetupFilter.doFilter(HibernateSessionSetupFilter.java:73)
    org.kablink.teaming.webdav.servlet.filter.ResourceDispatchFilter.doFilter(ResourceDispatchFilter.java:210)
    Note The full stack trace of the root cause is available in the server logs.
    [/PHP]


    I hope this helps someone.
0 Likes
3 Replies
psahukar Absent Member.
Absent Member.

Re: Filr 3.4.3 to 4.0 upgrade

Hi,

DId you manage to get the 8443 error resolved ?

Interestingly in our migration exercises we have not seen the issues you have mentioned here. We will discuss these points and get back with additional details as necessary.

Thanks,
Praveen Kumar
0 Likes
seba4
New Member.

Re: Filr 3.4.3 to 4.0 upgrade

Hi no i did return back to 3.4.3 because i have a lot to finish before i go to vacation and i can only continue with this after i get back in May.
0 Likes
seba4
New Member.

Re: Filr 3.4.3 to 4.0 upgrade

I have managed to find what was the problem. The main problem was that our filr version was still using root:password for MYSQL connection (probably from 1.x version) which was not ok. So i have started the upgrade process again but before that i have created and changed to user "filr" and now everything works fine.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.