ucba Absent Member.
Absent Member.
2128 views

Flir Tomcat timezone Settings

My Filr installation is being shutdown seemingly by a valid shutdown command. In trying to find out why, I found the logs had times that didn't match. It turned out the timezone used for tomcat is GMT. Here is what I did to put it to my timezone so my logs all match.

In the /opt/novell/filr/apache-tomcat/bin/catalina.sh file you will find the following line.

JAVA_OPTS="$JAVA_OPTS -Xms256m -Xmx8g -Xss2m -XX:MaxPermSize=512m -XX:+HeapDumpOnOutOfMemoryError -Dfile.encoding=UTF-8 -Duser.timezone=GMT -Djava.net.preferIPv4Stack=true"

Changing to


JAVA_OPTS="$JAVA_OPTS -Xms256m -Xmx8g -Xss2m -XX:MaxPermSize=512m -XX:+HeapDumpOnOutOfMemoryError -Dfile.encoding=UTF-8 -Duser.timezone=Australia/Brisbane -Djava.net.preferIPv4Stack=true"

and restarting filr is now giving me correct times in my logs. (You can insert your own timezone as relevant)
Still trying to sort why filr is being shutdown, but that's another story.
Tags (1)
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Flir Tomcat timezone Settings

Ucba,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

0 Likes
drfoster Absent Member.
Absent Member.

Re: Flir Tomcat timezone Settings

You do NOT want to change this timezone setting!!! The Filr code running in Tomcat is dependent on the JVM running in GMT. By changing this, you are likely to introduce other problems in the time/date calculations done within Filr.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.