lem9 Absent Member.
Absent Member.
1956 views

No net folders seen by users

Hi,
just installed Filr 1.0.1. Users are able to access their home directory correctly.

I have defined a few net folders, using a relative path containing a level-one subdirectory name of the volume. I set the appropriate (I think) access rights: first for allusers, then an explicit right for my own account.

In the Web GUI, nothing appears under Net Folders; what am I missing?

Regards,
Marc Delisle
0 Likes
18 Replies
sveld1 Absent Member.
Absent Member.

Re: No net folders seen by users

In the Administration Console> Net Folders> Select the properties of the given Net Folder, Select the Rights tab, did you enable 'Allow access to the Net Folder' for your account or a group you are a member of?

Best regards, Sebastiaan Veld If you find this post helpful and are logged into the web interface, show your appreciation and click on the star below...
0 Likes
lem9 Absent Member.
Absent Member.

Re: No net folders seen by users

Yes, I did that. First I did it for "allusers", then for my account.
0 Likes
jmarton2 Absent Member.
Absent Member.

Re: No net folders seen by users

lem9 wrote:

>
> Yes, I did that. First I did it for "allusers", then for my account.


While logged into the admin console as the admin user are you able to
see the NF? If no, then there's likely something incorrect with the
proxy user for the NF Server. If the admin user sees them ok but no
one else try performing a manual sync of the NF.

--
Your world is on the move. http://www.novell.com/mobility/
We know what your world looks like. http://www.novell.com/yourworld/

Joe Marton Emeritus Knowledge Partner
0 Likes
lem9 Absent Member.
Absent Member.

Re: No net folders seen by users

I believe you want me to check whether the admin user can see the net folder as a user, not in the admin console. Well, the admin user can see the net folder both in the admin console and as a user. I tried a manual sync of the net folder, it is supposed to be long?
0 Likes
jmarton2 Absent Member.
Absent Member.

Re: No net folders seen by users

lem9 wrote:

>
> I believe you want me to check whether the admin user can see the net
> folder as a user, not in the admin console. Well, the admin user can
> see the net folder both in the admin console and as a user.


Ok that's good, this shows the NF is configured properly and the proxy
user for the NF Server is good.

> I tried a
> manual sync of the net folder, it is supposed to be long?


It can depending upon the number of files and folders within the NF.
Any ideas how much content is in this particular NF?

--
Your world is on the move. http://www.novell.com/mobility/
We know what your world looks like. http://www.novell.com/yourworld/

Joe Marton Emeritus Knowledge Partner
0 Likes
lem9 Absent Member.
Absent Member.

Re: No net folders seen by users

I probably defined it at a too high level (my hope was that normal eDirectory rights would apply but I'm not familiar enough with Filr). So, this folder has hundreds of GB.
0 Likes
lem9 Absent Member.
Absent Member.

Re: No net folders seen by users

I deleted my net folder definition, created another one at a very low level (60 MB, 1500 files) and have the same problem. I also displayed via Filr the members of the group which I assigned to this folder, and I see my account name. But my account cannot see the folder via Filr.
0 Likes
Bob-O-Rama
Visitor.

Re: No net folders seen by users

Hi,

This is what I have learned so far. Not sure if its applicable to you or not. A lot of this is in the release notes... which are worth reading.

0. Make sure that both the Net Folder Volume's root as well as the specified Net Folder base path have an explicit RWCEMF trustee assignment for whatever proxy user you will use. The proxy user and the LDAP user can be the same provided the the LDAP user has Read rights to [Root]. He needs these rights to allow Filr to retrieve trustee account information specified on a volume which may refer to users you don't care about. I typically use the same privileged account for both the LDAP and the Net Folder Proxy. Without these rights, you can have issues.

1. Disable scheduled sync on the Net Folder Server ( or when you create a new one if applicable )
2. Create your Net Folder
3. Use the TEST button to test the connection.
4. Enable Just In Time Sync
5. Disable Scheduled Sync
6. When saving the do NOT sync when prompted.
7. Once created, go back in to the Net Folder and assign rights as desired ( typically allusers and let file system rights limit access )

Confirm proper operation:

Login as Admin --> Net Folders --> ( You should see the newly added Net Folder )
Navigate into the new Net Folder. It will take a while for Just In Time Sync to enumerate the folder contents. As users drill down, they will guide Filr through enumerating files. Initially this will cause a delay as users examine a folder for the first time. After that it gets quicker.

Once you have confirmed proper operation, then you can optionally manually Sync. This will provide guidance on how long a sync takes, allowing you to more intelligently specify a sync schedule. You can also enable indexing if needed. Indexing hundreds of GB of "stuff" can take days.

The KEY is enabling just in time sync, allowing your users to see things which Filr has not already enumerated via the manual / scheduled sync process. And enabling proper rights for the LDAP and Net Folder Proxy users.

Of course your issue may be entirely different. 😉 Please tell me if any of this helped.

-- Bob
0 Likes
lem9 Absent Member.
Absent Member.

Re: No net folders seen by users

Hi Bob,
My first attempt was on a folder located on Netware 6.5. I made another attempt on a folder located on OES 11 and everything is fine. Tomorrow I'll read your post and try again on Netware, thanks.
0 Likes
jmarton2 Absent Member.
Absent Member.

Re: No net folders seen by users

Bob-O-Rama wrote:

> 0. Make sure that both the Net Folder Volume's root as well as the
> specified Net Folder base path have an explicit RWCEMF trustee
> assignment for whatever proxy user you will use.


That's not needed. For example on my Filr server at home I use the
tree's admin user as the proxy account for all NF on OES. The admin
user doesn't have any explicit rights to anywhere in the filesystem and
simply as S to [Root] which flow down. Filr's happy.

--
Your world is on the move. http://www.novell.com/mobility/
We know what your world looks like. http://www.novell.com/yourworld/

Joe Marton Emeritus Knowledge Partner
0 Likes
jmarton2 Absent Member.
Absent Member.

Re: No net folders seen by users

lem9 wrote:

>
> I deleted my net folder definition, created another one at a very low
> level (60 MB, 1500 files) and have the same problem. I also displayed
> via Filr the members of the group which I assigned to this folder,
> and I see my account name. But my account cannot see the folder via
> Filr.


Well you had two problems I thought, one where you can't see files, and
the other where trying to run a manual sync just went on and on and on
and didn't complete. With this newer NF which is much smaller have you
performed a manual sync and waited for it to complete? With only about
1500 files it shouldn't take too long, especially if you have indexing
disabled.

BTW, I'd recommend leaving indexing disabled right now while
troubleshooting. Once you verify that NF access is working properly
you can go back and enable indexing.

--
Your world is on the move. http://www.novell.com/mobility/
We know what your world looks like. http://www.novell.com/yourworld/

Joe Marton Emeritus Knowledge Partner
0 Likes
Highlighted
lem9 Absent Member.
Absent Member.

Re: No net folders seen by users

Hi Bob,
I followed your suggestions (items 1 to 7) but my user still does not see the net folder which is located on Netware.
0 Likes
lem9 Absent Member.
Absent Member.

Re: No net folders seen by users

But this is indicated in the readme at item 7.5 (however the way Bob explains it is clearer, IMO). But I've tried that also, apparently with no luck.
0 Likes
jmarton2 Absent Member.
Absent Member.

Re: No net folders seen by users

lem9 wrote:

> But this is indicated in the readme at item 7.5 (however the way Bob
> explains it is clearer, IMO). But I've tried that also, apparently
> with no luck.


No, what's in the readme (actually item 9.5, not 7.5) is different.
That's if there are *no* trustees to the volume. That's an issue as
noted in the readme, but the proxy user itself doesn't have to be a
trustee of the volume.

--
Your world is on the move. http://www.novell.com/mobility/
We know what your world looks like. http://www.novell.com/yourworld/

Joe Marton Emeritus Knowledge Partner
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.