reddragon27284 Absent Member.
Absent Member.
3899 views

"Edit in place" not working.

Hi,

We have a new small Filr installation (Version 1.1.0.653-HP.665) and I've run into an issue with the ability to "Edit in place" from within the web interface.

This was working until one of two things changed. I applied all the patches to Filr, and also I have the latest version of Java on my workstation now.

One of these two things caused the edit in place to stop working. Unfortunately I didn't notice the problem until both had been applied so I don't know which one it was however I was suspecting the Java update of being the culprit.

I have tried reverting to a previous version of Java that I knew was working but still no joy. I have also tried tweaking security settings in java and the browser but again to no avail.

The symptom is that when selecting Edit This File from within the web interface my machine seems to show some disc activity (I'm assuming it's firing up the Java Runtime Environment) but then nothing. No security messages, errors or anything at all. I have tried this on another workstation and get the same result.

I found this article from a year ago referring to an issue in Filr 1.0.1:
http://www.novell.com/support/kb/doc.php?id=7014495

I was wondering if a similar thing has happened again or maybe this is a result of applying the patches.

Has anyone else had the same issue or come across a resolution?

Cheers.

-Iain.
0 Likes
21 Replies
Knowledge Partner
Knowledge Partner

Re: "Edit in place" not working.

reddragon27284;2346592 wrote:
Hi,

We have a new small Filr installation (Version 1.1.0.653-HP.665) and I've run into an issue with the ability to "Edit in place" from within the web interface.

This was working until one of two things changed. I applied all the patches to Filr, and also I have the latest version of Java on my workstation now.

One of these two things caused the edit in place to stop working. Unfortunately I didn't notice the problem until both had been applied so I don't know which one it was however I was suspecting the Java update of being the culprit.

I have tried reverting to a previous version of Java that I knew was working but still no joy. I have also tried tweaking security settings in java and the browser but again to no avail.

The symptom is that when selecting Edit This File from within the web interface my machine seems to show some disc activity (I'm assuming it's firing up the Java Runtime Environment) but then nothing. No security messages, errors or anything at all. I have tried this on another workstation and get the same result.

I found this article from a year ago referring to an issue in Filr 1.0.1:
http://www.novell.com/support/kb/doc.php?id=7014495

I was wondering if a similar thing has happened again or maybe this is a result of applying the patches.

Has anyone else had the same issue or come across a resolution?

Cheers.

-Iain.


We also have this after latest java jre updates. I've asked Novell, waiting for response... If you can then please open a SR.

Thomas
0 Likes
Luich Regular Contributor.
Regular Contributor.

Re: "Edit in place" not working.

We are experiencing exactly the same issue.

With the latest JRE 8 Update 31, "Edit this File" in the web interface does not work anymore.

We also are at Filr version 1.1.0.653-HP.665 (small deployment)

When we revert the Java installation to the latest 7 version (v.7 update 72) and uninstall the Java version 8 Update 31 it works again.
Upgrading to version v8 update 25 also works.

We have also tested this with uninstalling Java version 8 Update 31 and then install Java version 8 Update 25. This also works!

We tested this on Windows 8.1 Enterprise x64 installations.

For Java we used the x86 version.

Hopefully there will be an updated version of Java or a patch from Novell soon because we prefer to have the latest Java updates in place.

Cheers,

Marc
0 Likes
alsims Absent Member.
Absent Member.

Re: "Edit in place" not working.

We have an open SR with Novell about this. Hopefully they'll find a solution soon and let us know.
0 Likes
Knowledge Partner
Knowledge Partner

Re: "Edit in place" not working.

alsims;2347707 wrote:
We have an open SR with Novell about this. Hopefully they'll find a solution soon and let us know.


Please report back if they find a solution.

Thomas
0 Likes
Highlighted
alsims Absent Member.
Absent Member.

Re: "Edit in place" not working.

I noticed that Vibe recently received a hot patch to fix a very similar issue.

Details:
https://www.novell.com/support/kb/doc.php?id=7014494

As far as I understand, Filr & Vibe have a lot in common so I wonder if the problem we are experiencing with Filr is the same issue.

I don't see any patches for Filr yet that appear to address this issue so maybe one is due....hopefully. 🙂
0 Likes
reddragon27284 Absent Member.
Absent Member.

Re: "Edit in place" not working.

OK, so here's what I've found so far:

The problem started with the following Java versions and above:

Java 7 update 75
Java 8 update 31

Older versions still work.

In the Java console when attempting to use Edit In Place I see the error "javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: java.security.cert.CertPathValidatorException: Responder's certificate is not authorized to sign OCSP responses"

It looks like from what I've been reading that there have been quite a few changes to the way Java deals with SSL.

I've been talking with both Novell and our Certificate Authority. Novell advised me to re-install our SSL Certificate and ensure that the intermediate certificate was installed (I believe I had already done that but I did it again anyway). We have an EV SSL certificate.

That didn't resolve the problem so I have been talking with the CA to see if they can shed some light on the issue but they can't find any problems with the configuration of our Filr server or the SSL certs I have installed.

Still scratching my head on this one but I will post back here when I get it cracked.
0 Likes
jmarton2 Absent Member.
Absent Member.

Re: "Edit in place" not working.

alsims wrote:

>
> I noticed that Vibe recently received a hot patch to fix a very
> similar issue.
>
> Details:
> https://www.novell.com/support/kb/doc.php?id=7014494
>
> As far as I understand, Filr & Vibe have a lot in common so I wonder
> if the problem we are experiencing with Filr is the same issue.
>
> I don't see any patches for Filr yet that appear to address this issue
> so maybe one is due....hopefully. 🙂


I don't know if this issue is necessarily the problem outlined in the
TID. One of the recent Filr patches is the one for Poodle, and that
basically disabled SSLv3. However, that's what Windows 7 uses by
default for WebDAV, and that's where the problem is. I've heard this
can be solved by enabling FIPS within Windows 7 (GroupPolicy: System
cryptography: Use FIPS-compliant algorithms for encryption, hashing,
and signing=yes).

Can one of you try that to see if that resolves the issue?

--
Your world is on the move. http://www.novell.com/mobility/
Supercharge your IT knowledge. http://www.novell.com/techtalks/

Joe Marton Emeritus Knowledge Partner
0 Likes
Knowledge Partner
Knowledge Partner

Re: "Edit in place" not working.

jmarton;2349323 wrote:
alsims wrote:

>
> I noticed that Vibe recently received a hot patch to fix a very
> similar issue.
>
> Details:
> https://www.novell.com/support/kb/doc.php?id=7014494
>
> As far as I understand, Filr & Vibe have a lot in common so I wonder
> if the problem we are experiencing with Filr is the same issue.
>
> I don't see any patches for Filr yet that appear to address this issue
> so maybe one is due....hopefully. 🙂


I don't know if this issue is necessarily the problem outlined in the
TID. One of the recent Filr patches is the one for Poodle, and that
basically disabled SSLv3. However, that's what Windows 7 uses by
default for WebDAV, and that's where the problem is. I've heard this
can be solved by enabling FIPS within Windows 7 (GroupPolicy: System
cryptography: Use FIPS-compliant algorithms for encryption, hashing,
and signing=yes).

Can one of you try that to see if that resolves the issue?

--
Your world is on the move. http://www.novell.com/mobility/
Supercharge your IT knowledge. http://www.novell.com/techtalks/


Joe, doesn't help for us.. But disabling: "Perform certificate revocation checks for TLS-certificates" in Java Control Panel->Advanced solves the issue for us but that is not ideal..

I see this in the Java Console: security: Trust for: https://filr.company.com/ssf/applets/fileopen/kablink-teaming-fileopen-applet.jar has expired: Thu Jan 01 02:00:00 EET 1970

I wonder if this might help, looks like you need to do some extra steps when using wildcard certs: http://www.novell.com/support/kb/doc.php?id=7014775

Thomas
0 Likes
reddragon27284 Absent Member.
Absent Member.

Re: "Edit in place" not working.

thsundel;2349334 wrote:
Joe, doesn't help for us.. But disabling: "Perform certificate revocation checks for TLS-certificates" in Java Control Panel->Advanced solves the issue for us but that is not ideal..

I see this in the Java Console: security: Trust for: https://filr.company.com/ssf/applets/fileopen/kablink-teaming-fileopen-applet.jar has expired: Thu Jan 01 02:00:00 EET 1970

I wonder if this might help, looks like you need to do some extra steps when using wildcard certs: http://www.novell.com/support/kb/doc.php?id=7014775

Thomas


Changing the FIPS setting didn't work for me either however changing "Perform certificate revocation checks for TLS-certificates" in the Java settings did but like you said that isn't ideal.

I followed the steps you linked in but that didn't make any difference. I believe I had already done that anyway although in a slightly different way.
0 Likes
Knowledge Partner
Knowledge Partner

Re: "Edit in place" not working.

reddragon27284;2349347 wrote:
Changing the FIPS setting didn't work for me either however changing "Perform certificate revocation checks for TLS-certificates" in the Java settings did but like you said that isn't ideal.

I followed the steps you linked in but that didn't make any difference. I believe I had already done that anyway although in a slightly different way.


Ok thx for testing that, now I don't need to waste my time trying it 🙂

If you get any valuable info out of your support tickets then plz let us other also know 😉

Thomas
0 Likes
reddragon27284 Absent Member.
Absent Member.

Re: "Edit in place" not working.

I'm curious to know which CA everyone's using. We're using GlobalSign.

I doubt it's related to the problem but I'd just like to rule it out.
0 Likes
Knowledge Partner
Knowledge Partner

Re: "Edit in place" not working.

Reddragon27284,
> I'm curious to know which CA everyone's using


Thomas uses DigiCert as do we.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
reddragon27284 Absent Member.
Absent Member.

Re: "Edit in place" not working.

AndersG;2349485 wrote:
Thomas uses DigiCert as do we.


Cool, that answers that then. Thanks. 🙂
0 Likes
reddragon27284 Absent Member.
Absent Member.

Re: "Edit in place" not working.

Just applied security update 4. No joy unfortunately.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.