Dynamicacg202 Frequent Contributor.
Frequent Contributor.
3369 views

Errors with WebInspect 18.10 scans SPI.Scanners.Web.Framework

I am recieving multiple issues with scans for 18.10 WIE.

Check error, session:(null), CheckID:810, engine:adaptive agent, error:compile failed:

Check error, session:(null), CheckID:810, engine:adaptive agent, error:agent not loaded:

SPI.Scanners.Web.Framework.AllIAuditCapableloader System.ArgumentException: The parameter is incorrect. (Expection from HRESULT: 0x80070057 (E_INVALIDARG))

SPI.Scanners.Web.SecureBase.Check :in GetSmartChecksForAudit, no EngineType conversion error, obsolete engineTypeOld:ABS, engineTypeNew:3856

 

 

0 Likes
8 Replies
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Errors with WebInspect 18.10 scans SPI.Scanners.Web.Framework

What version of sensor is this ? Did you upgrade sensor recently ? I would recommend reinstalling sensor (only sensor) and see if that helps. Looks like a securebase corruption issue to me.  Thanks

Dynamicacg202 Frequent Contributor.
Frequent Contributor.

Re: Errors with WebInspect 18.10 scans SPI.Scanners.Web.Framework

Thanks, we are on 18.10 for our sensors. We did just recently upgrade. Are the sensors able to be re-installed with re-intalling WebInspect Enterprise?

0 Likes
Dynamicacg202 Frequent Contributor.
Frequent Contributor.

Re: Errors with WebInspect 18.10 scans SPI.Scanners.Web.Framework

Correction:

Thanks, we are on 18.10 for our sensors. We did just recently upgrade. Are the sensors able to be re-installed without re-intalling WebInspect Enterprise?

0 Likes
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Errors with WebInspect 18.10 scans SPI.Scanners.Web.Framework

Yes, you dont need to reinstall WIE server. Just the sensor (WI standalone). Yeah upgrade can do that.. we have a bug open on that issue. Thank you!

Dynamicacg202 Frequent Contributor.
Frequent Contributor.

Re: Errors with WebInspect 18.10 scans SPI.Scanners.Web.Framework

Thanks again, I will give it a try. Is there anything else you used as a workaround?

0 Likes
Dynamicacg202 Frequent Contributor.
Frequent Contributor.

Re: Errors with WebInspect 18.10 scans SPI.Scanners.Web.Framework

Reinstalling the sensor did not work. Looking for other options now.

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Errors with WebInspect 18.10 scans SPI.Scanners.Web.Framework

Please open a support ticket with all the details so someone can assist you. Thanks

0 Likes
Dynamicacg202 Frequent Contributor.
Frequent Contributor.

Re: Errors with WebInspect 18.10 scans SPI.Scanners.Web.Framework

I did and it is not going well, thanks.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.