KailashPatra
New Member.
3859 views

Fortify 16.20 crashing Visual Studio

Hi Team,

I am tryig to use Fortify extension with Team Foundation server to automate scanning. For one of the solution I am not able to successfully build and scan using fortify.

The solution contains 13 projects. Build server where fortify is running is 64 bit windows server with 16 GB RAM.

Whenever I run the build it failed at translation phase. Also I tried using command line. I used below format.

sourceanalyzer -b my_buildid devenv Sample1.sln /REBUILD debug

Everytime I run this command it crashes visual studio. I even tried to use below command and scan individual projects but getting error as mentioned below.

sourceanalyzer -dotnet-version <version> -b <build_id>
-libdirs <ProjOne/Lib;ProjTwo/Lib> <project_1_source_files> <project_2_
source_files>

ERROR: Translator execution failed. Please consult the Troubleshooting section of the User Manual.
Translator returned status -2147467261:

DOTNET-DEBUG: Unhandled exception: Object reference not set to an instance of an object.

However the build and scan is working fine if I run it inside VS using the plugin. If anyone can help with this issue, it will be a great help. I am trying to make this automated for 3 weeks now without any luck.

Regards,

Kailash

Labels (3)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.