Highlighted
Respected Contributor.. dgarozzo Respected Contributor..
Respected Contributor..
1178 views

Fortify SCA - Problems Scanning Swift iOS Code

I am just starting to scan Swift code, and I'm running into problems.

First, I'm confused as to what versions of Swift are supported. I know 19.1.1 now support Swift 5.0. And if I look in to the private-bin folder, I see swift-translator-5.0, as well as 4.2.1, 4.1, 4.0.3. However, if I look in the 18.1 release, I also see swift-translator-3.1, 3.0.2, 3.0.1, 3.0, 2.3, and 2.2. Does this mean that the current version, 19.1.1, doesn't scan swift 2.x or 3.x code?

Next, and more importantly, when I run sourceanalyzer, it appears to be making calls to swift-translator-4.2.1 with an argument of -disable-bridging-pch, which is an unknown argument and it just errors out on the *.swift code. Anybody else ever experience anything like this?

I'm running Fortify SCA v19.1.1 (and had the same problem with 19.1.0). I haven't tried scanning with v18.10 yet.

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.