Captain Captain

Gradle-SCA Integration Build ID Not Found

I am performing a grade scan integrated with SCA using sourceanalyzer commands as per SCA Guide document. SCA Clean and Translation phase were successful and gradle build also didn't throw any error however when I initiate the Scan phase to generate FPR, SCA throws error as "[error]: Unable to load build session with ID "testscan". Below are my environment details


sourceanalyzer -b testscan -verbose -clean
sourceanalyzer -b testscan -verbose gradle clean compile
sourceanalyzer -b testscan -verbose -scan -f testscan.fpr

Environment Details:

SCA Version: 19.1.2
Gradle Version: 2.13
Java Version: 1.8.0_231
Rulepacks: 2020 Q2


sourceanalyzer -show-build-ids command also didn't show any build ids. Has anyone encountered the issue before and was there any resolution to it?


Tags (2)
2 Replies
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Have you tried using, eg gradle clean build, instead of compile?
sourceanalyzer -b testscan -verbose gradle clean build

Captain Captain

@richard.pinaroc1 I have tried all possible gradle tasks and it didn't work either. However, the same sourceanalyzer command works in 20.1 SCA but not in 19.1 SCA

I suppose that it could be a bug within the SCA

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.