Highlighted
Visitor.
212 views

Ignoring languages on Fortify translations with com.fortify.sca.DISabledLanguages

Does anyone understand how this java option for disabling languages during a sourceanalyzer translate, is truly suppose to work?

-Dcom.fortify.sca.DISabledLanguages=python:java

Every time I use this option and specify the languages of my choice, for example java or python above, I seem to still have the files included in my NSTs and therefore included in my scans.

0 Likes
2 Replies
Highlighted
Contributor.
Contributor.

Have you tried this?

sourceanalyzer -b -disable-language python:java

 

I added it to Core/config/fortify-sca.properties, and works for us.

0 Likes
Highlighted
Visitor.

Thanks for the reply however SCA implements this option/argument invoking the same Property Key constant as com.fortify.sca.DISabledLanguages.  So essentially it is the same thing for SCA, the one issue that may be relevant here is our code base is massive, well over several millions of lines of code.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.