Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.
10301 views

Jobs stuck in Scheduled for Processing

Jump to solution

There is a job stuck in Scheduled for Processing repeatedly. Cancelling the upload and re-uploading the FPR results in the job getting stuck again and it never processes. Restarting the application server also has no effect on processing the job.

Tags (1)
0 Likes
1 Solution

Accepted Solutions
Absent Member.
Absent Member.

You can try changing the job scheduler execution strategy to see if it helps to process it. To get to the option, make sure you're using the new UI. In SSC 4.4 and 4.3, the new UI is available by clicking on the Preview New Dashboard in the top right. In SSC 16.10, the new UI is the default UI. Click on Administration and under Configuration, you should see a Scheduler section. In this section, there is an option to change the Job Execution Strategy. The default value for this option is Conservative, please try changing it to Aggressive. You will need to restart the application server after making this change.

View solution in original post

0 Likes
3 Replies
Absent Member.
Absent Member.

You can try changing the job scheduler execution strategy to see if it helps to process it. To get to the option, make sure you're using the new UI. In SSC 4.4 and 4.3, the new UI is available by clicking on the Preview New Dashboard in the top right. In SSC 16.10, the new UI is the default UI. Click on Administration and under Configuration, you should see a Scheduler section. In this section, there is an option to change the Job Execution Strategy. The default value for this option is Conservative, please try changing it to Aggressive. You will need to restart the application server after making this change.

View solution in original post

0 Likes

I started getting this same error after a server reboot today. I tried the suggested change to the Execution Strategy to no avail. The ssc.log file is full of these:

[ERROR] com.fortify.manager.service.scheduler.SchedulerManagerImpl - Error during triggering of job ACTIVITIES_ALERT_DISPATCH

They were accumulating in the log so fast that I had to shut off Tomcat. Help, please!

0 Likes
Cadet 1st Class
Cadet 1st Class

we are running SSC 17.2 on Linux and the change to aggressive doesn't change on a reboot. Are there other ideas to get this setting changed? 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.