Ensign
Ensign
691 views

MySQL my.cnf file settings recommended by Microfocus preventing MySQL from starting (8.0.21)

(Versions : 20.1 Fortify, Apache 9.0.39, MySQL 8.0.21)

Hello! We are getting close to finishing our 20.1 deployment but running into issues with the MySQL DB.

Using this guide : https://www.microfocus.com/documentation/fortify-software-security-center/2010/SSC_Help_20.1.0/Content/SSC_UG/Config_MySQL_DB.htm

Some settings that we set cause mysqld to not run. The commented out ones below appear to break mysqld from starting. 

When I try to run the mysql create-tables script during install (as specified), I get a few errors in the process relating to :  ERROR 1118 (42000) : Row size too large. The maximum row size for the used table type, not counting BLOBS, is 65535. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs. And of course, trying to do the seed.zip files during install also fails.  "Unable to process the Fortify_Process_Seed_Bundle-2020_Q1_0024.zip. Seeding failed: Unable to seed all init seed bundles."

 

[mysqld]

innodb_log_file_size = 2G
innodb_lock_wait_timeout = 300
#query_cache_type = 1
#query_cache_size = 64M
innodb_buffer_pool_size = 512M
default-storage-engine = INNODB
#innodb_file_format = Barracuda
#innodb_large_prefix =1
#sql_mode = TRADITIONAL
max_allowed_packet = 1G

[mysqldump]
max_allowed_packet = 1G

0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

As you are running MySQL 8.0, please try the following settings to see if it resolves your issue:

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0
#
# Modifications for Fortify SSC and Mysql 8
#
max_allowed_packet = 1G
innodb_log_file_size = 512M
innodb_lock_wait_timeout = 300 
#query_cache_type = 2
#query_cache_size = 128M
innodb_buffer_pool_size = 512M
default_storage_engine = INNODB
#innodb_file_format = Barracuda
#innodb_large_prefix = 1 
sql_mode = TRADITIONAL

collation-server=latin1_general_cs
character-set-server=latin1

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

[mysqldump]
max_allowed_packet = 1G
0 Likes
Ensign
Ensign

Your settings work, mysqld starts normally. But when seeding the table with the create-tables.sql in the mysql folder, I'm still getting the ERROR 1118 (42000):  Row size is too large. 

Are you seeing those?

0 Likes
Micro Focus Expert
Micro Focus Expert

Negative. I did not receive that error. At this point, my recommendation would be to open a ticket with support and provide the the following to support for further analysis: ssc.log and ssc_seeding.log.

0 Likes
Ensign
Ensign

ebell,

We reached out to tech support but in the meantime, added line "innodb_file_per_table=1" to my.cnf, reran create-tables.sql script and voila, no errors. This allowed us to seed the two Process and Report files successfully, and we are off to the races.

 

Thanks again for your help!!!!

0 Likes
Micro Focus Expert
Micro Focus Expert

You're welcome. Glad you were able to get this up and running. I will make a note of this and possible inclusion into the documentation.

Thank you for following up and letting us know.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.