ls613 Contributor.
Contributor.
4188 views

SSC 404 error when deploying with Tomcat

I am trying to set up the Software Security Center, and after following the documentation for a Tomcat deployment I get this page:ssc 404.PNGI've tried various URLs, all with the same result. The logs don't show any errors. Has anyone else experienced this?

 

Labels (1)
Tags (2)
0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

Re: SSC 404 error when deploying with Tomcat

Recheck your Tomcat configuration. If your Tomcat is indeed on port 8080, then your URL localhost:8080/ssc should have opened SSC. If Tomcat is set on another port, you will need to adjust that. Check the SSC.LOG file found in the Tomcat logs directory for more information. Did the SSC.WAR file deploy fully and generate the expected /web-apps/ssc/ folder under the Tomcat directories?

-- Habeas Data
Micro Focus Fortify Customers-Only Forums – https://community.softwaregrp.com/t5/Fortify/ct-p/fortify
0 Likes
ls613 Contributor.
Contributor.

Re: SSC 404 error when deploying with Tomcat

The connector port is set to 8080, and when I put SSC.WAR in the web-apps directory it created an ssc folder and shows as running in the Tomcat admin screen. When I try to hit the page, the log file comes up with a few info lines as well as one error and a couple of warnings. I've taken out all of the info lines, this is what's left:

2017-11-09 09:30:11,758   [ERROR] com.fortify.manager.DAO.fulltext.ModelMappingFactoryImpl - Fulltext search is disabled because searchIndex.location property has no value
2017-11-09 09:30:47,715   [WARN] com.fortify.manager.service.ldap.impl.LdapConfigRestorerImpl - Not loading ldap properties into DB because enabled flag is false.
2017-11-09 09:31:14,494   [WARN] com.fortify.manager.service.runtime.RuntimeControllerConnectionConfiguration - Runtime integration disabled
2017-11-09 09:32:37,976   [WARN] com.fortify.manager.web.filters.HostHeaderFilter - HTTP Host header value localhost:8080 does not match host.url property for request URI /ssc/

0 Likes
Outstanding Contributor.. pprofili Outstanding Contributor..
Outstanding Contributor..

Re: SSC 404 error when deploying with Tomcat

Check the ssc.log file for details. There is clearly some issue with the SSC application, some misconfiguration most likely - the log will help guide you to the cause.

0 Likes
ls613 Contributor.
Contributor.

Re: SSC 404 error when deploying with Tomcat

I just posted the non-info lines of my ssc.log, the relevant part is this:

 

2017-11-09 09:30:11,758   [ERROR] com.fortify.manager.DAO.fulltext.ModelMappingFactoryImpl - Fulltext search is disabled because searchIndex.location property has no value
2017-11-09 09:30:47,715   [WARN] com.fortify.manager.service.ldap.impl.LdapConfigRestorerImpl - Not loading ldap properties into DB because enabled flag is false.
2017-11-09 09:31:14,494   [WARN] com.fortify.manager.service.runtime.RuntimeControllerConnectionConfiguration - Runtime integration disabled
2017-11-09 09:32:37,976   [WARN] com.fortify.manager.web.filters.HostHeaderFilter - HTTP Host header value localhost:8080 does not match host.url property for request URI /ssc/

0 Likes
andersonshatch Honored Contributor.
Honored Contributor.

Re: SSC 404 error when deploying with Tomcat

SSC is running, but you're being denied access on that URL (localhost:8080/ssc) as it does not match the URL you set in the configuration tool

This message aludes to that:

2017-11-09 09:32:37,976   [WARN] com.fortify.manager.web.filters.HostHeaderFilter - HTTP Host header value localhost:8080 does not match host.url property for request URI /ssc/

In the SSC config tool, step 1 asks you for the URL users will access SSC at, and there is an optional box "HTTP Host header validation" which if checked, will enforce that SSC can only be accessed at the URL you specified above.

So, you can either access SSC at the host/url you selected on that page, or disable the HTTP Host header validation option, save the changes and re-deploy the WAR.

Also, I noticed from one of the comments you have since edited out that your heap size was way too small:

2017-11-09 09:31:17,876   [INFO] com.fortify.manager.web.listeners.AppInitializer - JVM Heap size: 247MB

The minimum is 4GB. Please adjust your app server's max heap (-Xmx) and restart.

-Josh
Fortify L3 Support Engineer

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.