gp1988 Trusted Contributor.
Trusted Contributor.
10072 views

SSC change mysql fortify user password

Jump to solution

Hello, 

I have changed my fortify mysql user password, now SSC is not able to connect to DB (logs gives database permission denied because the password is not updated). 

I have seen that the password is saved on <fortify-ssc-root>/conf/datasource.properties, but this is encrypted. 

Is it possible to properly change the encrypted password in this file in order to fix the problem?

Thanks in advance

 

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
mlacasse Super Contributor.
Super Contributor.

Re: SSC change mysql fortify user password

Jump to solution

Hi, 

If you go under the .fortify/ssc/conf look for version.properties.  

Change the setting...

maintenance.mode = false

to true

Restart tomcat and see if that allows you back into maint mode. 

-Mark 

Fority Support

0 Likes
5 Replies
mlacasse Super Contributor.
Super Contributor.

Re: SSC change mysql fortify user password

Jump to solution

Hi,

What version of SSC are you using?  If this is 17.20 the process is very easy. (instructions below for 17.20+)

1. If you go under Administration --> Configuration --> Maintenance Mode:

2. Check "Set to maintenance mode" and hit save

3. Restart Tomcat

4. Login with the token stored locally on the server (under the .fortify directory see ssc deployment docs if your unsure on this)

5. Proceed to the data source section and update your Mysql user/pass and test the connection. 

6. Click through and finish, then restart tomcat and you should be good to go.

Mark

Fortify Support

0 Likes
gp1988 Trusted Contributor.
Trusted Contributor.

Re: SSC change mysql fortify user password

Jump to solution

Thanks for the answer!

The version is 17.20 but unfortunately Apache Tomcat has been restarted  after the db user change but before setting the configuration mode on ssc... so when I try to browse the ssc it gives errors (blank page, because the application server is not able to connect to DB with wrong credentials).

How do you think that I could resolve?

0 Likes
Highlighted
mlacasse Super Contributor.
Super Contributor.

Re: SSC change mysql fortify user password

Jump to solution

Hi, 

If you go under the .fortify/ssc/conf look for version.properties.  

Change the setting...

maintenance.mode = false

to true

Restart tomcat and see if that allows you back into maint mode. 

-Mark 

Fority Support

0 Likes
gp1988 Trusted Contributor.
Trusted Contributor.

Re: SSC change mysql fortify user password

Jump to solution

Great, you always have the right answer to my questions 🙂

Thx very much!

sligade Trusted Contributor.
Trusted Contributor.

Re: SSC change mysql fortify user password

Jump to solution

Hello,

my version is 16.20 how I can update my password? There is no maintenance mode under administration 😞

S

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.