Ensign
Ensign
313 views

WIE Installation SQL error

Hello, my team and I have been trying to install WIE 19.0 but we have encountered an error during the step "loading default zero login macro" which aborts the process. I have already installed WIE in different occasions and the requirements are met, but this error is not mentioned in any community post or documentation. We already tried support but they only told us to check the requirements, which are met.

Thanks for the assistance in advance. Here is the log trace:

2020-10-15 14:41:56,753 INFO [1] Loading default zero login macro...

2020-10-15 14:41:56,800 FATAL [Database Init] Unable to initialize Repository
System.Exception: The select clause is not valid.
at HP.ASC.AMP.EFDAL.Entity.ScanSettingsTempFile.GetFieldAliasFromFieldNameSqlMapping(String alias)
at HP.ASC.AMP.EFDAL.LinqSQLParser.ParseSelect(String selectClause)
at HP.ASC.AMP.EFDAL.LinqSQLParser..ctor(String sql, ObjectTypeConstants type)
at HP.ASC.AMP.EFDAL.Entity.ScanSettingsTempFile.DeleteData(Expression`1 where, QueryOptimizer optimizer, ContextStartup startup, String connectionString)
at AmpManagerWS.Impl.ScanSettingsManager.initializeDefaultMacro(String defaultMacroFile, String connString)
at WieInitialize.ProcessAmpInitialize.initializeDefaultMacro()
at WieInitialize.ProcessAmpInitialize.initializeRepository()
2020-10-15 14:41:56,815 ERROR [Database Init] An error occurred while initializing the Repository.

System.Exception: The select clause is not valid.
at HP.ASC.AMP.EFDAL.Entity.ScanSettingsTempFile.GetFieldAliasFromFieldNameSqlMapping(String alias)
at HP.ASC.AMP.EFDAL.LinqSQLParser.ParseSelect(String selectClause)
at HP.ASC.AMP.EFDAL.LinqSQLParser..ctor(String sql, ObjectTypeConstants type)
at HP.ASC.AMP.EFDAL.Entity.ScanSettingsTempFile.DeleteData(Expression`1 where, QueryOptimizer optimizer, ContextStartup startup, String connectionString)
at AmpManagerWS.Impl.ScanSettingsManager.initializeDefaultMacro(String defaultMacroFile, String connString)
at WieInitialize.ProcessAmpInitialize.initializeDefaultMacro()
at WieInitialize.ProcessAmpInitialize.initializeRepository()
2020-10-15 14:42:48,430 INFO [1] Aborting Installation...
2020-10-15 14:42:48,446 INFO [1] Incomplete
2020-10-15 14:42:48,446 INFO [Database Init] Incomplete

Labels (1)
0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

Please provide both the installation and initialization logs for further analysis. Also, I would like to review the support case you had open. You can PM me the case number instead of posting it in the open forum.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.