275 views

WIE Scan Visualization Screen load fails - upgrade to 18.20

Just upgraded Webinspect Enteprise to v18.20, and I cannot access the scan visualization screen (for both old scans, and new ones run on 18.20).  At first glance, everything else seems to work, including creating a new scan, running it on the sensor and seeing the scan completed from the main Scan.aspx page.

The front end indefinitely spins on the loading circle at 100%, and manager trace logs seem to indicate an issue retrieving the Scan ID from the database (below)

2019-11-22 14:40:23,465 ERROR [77] Exception occured (handleExceptionWithRetry)
System.NullReferenceException: Object reference not set to an instance of an object.
at HP.ASC.DistributedScanner.Common.SQLServerScanDataAccess.GetScanBasicByID(Guid scanID)
at HP.ASC.DistributedScanner.Services.ScanVisualizationManager.GetScanBasicByID(Guid scanID)

Labels (1)
0 Likes
0 Replies
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.