Highlighted
tarveen Absent Member.
Absent Member.
5152 views

WebInspect API not working after SQL upgrade

Hi,

The webInspect API was working fine on the SQL server 2008. By fine, I mean, I was able to create/start new scans etc. But recently, we upgraded the SQL server to 2014 version and suddenly I cannot create/start scans. I keep getting this message: An error has occured.

Few more points:

1. I can create/start scans from the UI and they all work fine. Its just the API seems to have stopped working.

2. I turned on the debug level and have attached the log file.

3. I am using this curl command:

curl -d "settingsName=<Settings file name>&overrides={\"ScanName\":\"Test\",\"StartUrl\":\"http://zero.webappsecurity.com\",\"CrawlAuditMode\":\"CrawlAndAudit\",\"StartOption\":\"Url\"}""http://<Host>/webinspect/scanner/"

If you have nay idea, what might be causing this issue or how I can debug it, please let me know.

Thanks,
Tarveen

Labels (1)
Tags (1)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.