Regular Contributor.
Regular Contributor.
170 views

WebInspect Enterprise Windows user login to SQL doesn't work

Jump to solution

WiE 19.2 issue

I have in my environmet SQL server 14 and installing WIE. We would like to use dbo-user (service user) defined via AD for the installation but WIEInitializer is not able to connect to the base with those credentials. We have done a workaround with local SQL user and they work, so connection is ok.

Our service user is defined as dpo for WIEdatabase and SSCdatabase and it works fine with SSC. For SSC needs  running Tomcat as that service user.

If you have ideas how configure windows login in WIE or the win2016 server running it and/or AD and/or SQL server I would appriciate such information greatly. This local user use is not company best practice compliant, we should use AD users always when possible.

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: WebInspect Enterprise Windows user login to SQL doesn't work

Jump to solution
The documentation states:

Important! The Fortify WebInspect Enterprise server application uses the IIS application pool identity. Because the IIS application pool is not a true Windows account, Fortify WebInspect Enterprise cannot use Windows authentication for the database connection. Customers must create a SQL Server account that can be used for the database connection.

View solution in original post

0 Likes
3 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: WebInspect Enterprise Windows user login to SQL doesn't work

Jump to solution
The documentation states:

Important! The Fortify WebInspect Enterprise server application uses the IIS application pool identity. Because the IIS application pool is not a true Windows account, Fortify WebInspect Enterprise cannot use Windows authentication for the database connection. Customers must create a SQL Server account that can be used for the database connection.

View solution in original post

0 Likes
Highlighted
Regular Contributor.
Regular Contributor.

Re: WebInspect Enterprise Windows user login to SQL doesn't work

Jump to solution

OK thanks! 

Shouldn't MF take off the alternative of windows user connectivity to the database from Initializer if it doesn't work? It only creates confucion. 

This case is solved.

0 Likes
Highlighted
Regular Contributor.
Regular Contributor.

Re: WebInspect Enterprise Windows user login to SQL doesn't work

Jump to solution

Hi

There are two places in the initializer where the login method is asked and your answer is valid for the WIE as database user.

WIE is not able to be a windows serviceuser. That was understood and that is what the documentation is refering to.

The windows login is for installing the database in the initializer process and that was not working. Reason for that was that the Windows auhentication box was not checked in IIS security settings. NOW windows user can be used to install the database as we found the reason.

Case solved

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.