Commander
Commander
585 views

Webinspect 20.1.0 failed to launch truclientbrowser

Previously I used webinspect on version 19.1.0. then I upgraded the version via smartupdate to the latest version 20.1.0 but every time I try to do a scanning it always has problems.
namely "failed to launch truclientbrowser" please help.

in previous versions the scan was running normally

following the scan log :

9/4/2020 9:50:10 AM Error Crawler error, session:306E42D0F653E7CFA6720D7F15AE506B, error:Failed to launch truclientbrowser
9/4/2020 9:50:09 AM Error SPI.Parsers.Script.Remoting.ScriptExecWrapper :in get_parser, __parser==null
9/4/2020 9:50:09 AM Error SPI.Parsers.Script.Remoting.ScriptExecWrapper WebInspectWCFService.LaunchTCException: Failed to launch truclientbrowser

 

Thanks.

0 Likes
3 Replies
Micro Focus Expert
Micro Focus Expert

There are a number of reasons for this message:

1. Endpoint protection software
2. Permissions
3. Corrupt install or upgrade

Ruling out antivirus or other endpoint protection as an issue, my recommendation would be to uninstall WebInspect and then install a fresh installation of 20.1.

We’ve had a small percentage of instances where upgrading from 19.x to 20.1 experiences this issue after upgrading via smartupdate.

This is not typically an answer I would give, but may be the quickest resolution.

Let’s talk about endpoint protection, I’ve seen environments where prior versions worked with AV installed and then not with 20.1. This is the reason we recommend disabling endpoint protection software during scans.
0 Likes
Commander
Commander

1. I don't use any antivirus, I only have Windows Defender and I've tried turning it off and excluding the webinspect folder.

2. I have logged in using administrator and running with administrator.

3. maybe I will re-download the installer webinspect version 20.1.0, I've tried fresh install but still experience the same thing

 

I'll let you know after I try to re-download the inspect web installer and try a fresh install.

 

Thanks

 

 

0 Likes
Micro Focus Expert
Micro Focus Expert

If installing a clean instance of WebInspect does not resolve the issue, please open a ticket with support and provide the following:

  • Provide an export of a scan with traffic and logs
  • Provide the logs from Folder “00000000-0000-0000-0000-000000000000” under path: %localappdata%\HP\HP WebInspect\Logs
  • Export of the Application and System event logs
    • wevtutil epl System %userprofile%\Desktop\SystemLog.evtx
    • wevtutil epl Application %userprofile%\Desktop\ApplicationLog.evtx  
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.