Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
goldfish Trusted Contributor.
Trusted Contributor.
770 views

Webinspect sensor service not running

Hi

We are facing an issue in new Installation .
We have used SQL express 2014 SP2 .
WEBINSPECT 18.10

After successful implementation we run the webinspect application .

Applied the license . And performed a scan and closed the console after that .

Now next moment when we try to open the webinspect , the console doesn't appear .

We verified in Services that " sensor service " is not running , tried running manually but no luck .

Hence for checking the issue went through windows event logs found error " service cannot be started , the handle is invalid "
0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

Re: Webinspect sensor service not running

A WebInspect desktop license is not necessary to install a Sensor.  You would install WebInspect desktop, remove its short-cut from the Desktop, and do not open the WebInspect GUI at all.  I just wanted to put that out there to clear up any misunderstanding for other readers.  you *could* run both a Sensor and open WebInspect on a single machine, but your overall scan performance could if both were running scans at the same time.

 

You should launch the Fortify Monitor program, so it provides an icon in the Windows System Tray.  Right-click that Monitor icon and select the option for Configure Sensor.  Key field you will need for your scenario of using SQL Express include:

  • Manager URL = https://{WIE server name}/wie
  • Username \ Password = credentials for the Sensor User account you defined earlier in the WIE Console. Sensor User needs to be a plain user-level account in the OS, and it should never be used to log into the WIE Console nor its web console.  FYI
  • Advanced options = (only needed when using MSSQL rather than SQL Express....)
  • Service Account = Local System account  (Other accounts needed when using MSSQL)

See if you can now press Start and start the Sensor.  If not, open the Windows Servcies Control panel, and see what you can do to the WebInspect Sensor service to get it started there.  Sometimes changing it to the current user's account is needed, based on the OS and Group Policies leveraged within your network.

If you still cannot get it operational, review the Sensor_trace.log file and/or send it to Fortify Support (https://softwaresupport.softwaregrp.com) for assistance.  They may also want the Manager's trace.log file off of the WIE Manager server.


-- Habeas Data
Micro Focus Fortify Customers-Only Forums – https://community.softwaregrp.com/t5/Fortify/ct-p/fortify
Tags (1)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.