Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Maxim1
New Member.
3367 views

sourceanalyzer fails to generate .nst files

I've been trying to use Fortify on an Ubuntu 16.04 machine, but when I run the build through sourceanalyzer, the .nst files are not generated in ${HOME}/.fortify/sca16.1/build/${PROJECT_NAME} directory. The build is successful, and the same commands work on other machines (and by "work" I mean generate the folder structure with .nst files in it), bur for some reason on this specific machine I get nothing.

.fortify/sca16.1/log/sca.log does not contain any entries except for the "clean" command I ran prior to the build. The sourceanalyzer log doesn't seem to contain any errors either, but something obviously is wrong. I also ran it with the "-debug" option, what else can I do to try and find the problem?

1 Reply
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: sourceanalyzer fails to generate .nst files

How are you running sourceanalyzer for the translation? Are you running sourceanalyzer directly, using a build integration, from an IDE plugin? You could try adding the -verbose, -debug and -logfile options to get more information about the translation process.

Does a command like 'sourceanalyzer -b <buildid> -show-files' show any files after running the translation? SCA provides various options for storing the NST files in a non-default location, maybe your SCA is somehow configured to store the files elsewhere. 

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.