Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Highlighted
mysteini Absent Member.
Absent Member.
226 views

How to fix?: RT: 75 - Custom error, Unable to establish the connection, errorcode: 6)

Jump to solution

I get this message when trying to monitor a Linux system using SSH

 

does anyone know how to fix this?

0 Likes
1 Solution

Accepted Solutions

RE: How to fix?: RT: 75 - Custom error, Unable to establish the connection, errorcode: 6)

Jump to solution
Coincidentally, there is also a similar discussion today, see community.microfocus.com/.../silk-performer-with-ssh.

Grab the .sep file for "vmstat (ssh)" from Monitors sub directory under the Performer install path, then extract it like I wrote in the mentioned post. You can also rename it to .ltz and open it it Silk Performer directly. Then:
- Open the contained .bdf-Script
- customize the project attributes <Strg + Alt + A>: hostname/IP, login, pwd
- run as try script (<F8>)
In theory you should get the same error as during monitoring.
But now - by double clicking the error - you can directly jump to the source code line.

Check the "plink.exe" version that is included in the .sep file.
If it is older than the putty version that you used on your load controller, please exchange it with the current version.
Recently, I had a similiar problem (I don't remember the exact error message or code) using the Performer built in .sep files when trying to connect to new SSH servers.
0 Likes
4 Replies

RE: How to fix?: RT: 75 - Custom error, Unable to establish the connection, errorcode: 6)

Jump to solution
Please add more details to your request for a helpful answer:
- Do you try to set up system monitoring using Silk Performance Explorer?
- Did you use one of the SSH monitoring templates included with the performer (which one)?
- Or do you use a custom template (*.sep file)?
- Can you establish a SSH session from your load controller to the Linux system with SSH client (putty.exe)?
- Does the Linux server support username+password authentication and/or key based auth? Is your public key contained in ~/.ssh/authorized_keys (usually) for your login?
0 Likes
mysteini Absent Member.
Absent Member.

RE: How to fix?: RT: 75 - Custom error, Unable to establish the connection, errorcode: 6)

Jump to solution
1. Yep I used Silk performance Explorer
2. I tried Linux -> vmstat (ssh) and Putty Session
3. no custom *.sep
4. Putty connection works just fine
5. authentification is done with username + password
0 Likes

RE: How to fix?: RT: 75 - Custom error, Unable to establish the connection, errorcode: 6)

Jump to solution
Coincidentally, there is also a similar discussion today, see community.microfocus.com/.../silk-performer-with-ssh.

Grab the .sep file for "vmstat (ssh)" from Monitors sub directory under the Performer install path, then extract it like I wrote in the mentioned post. You can also rename it to .ltz and open it it Silk Performer directly. Then:
- Open the contained .bdf-Script
- customize the project attributes <Strg + Alt + A>: hostname/IP, login, pwd
- run as try script (<F8>)
In theory you should get the same error as during monitoring.
But now - by double clicking the error - you can directly jump to the source code line.

Check the "plink.exe" version that is included in the .sep file.
If it is older than the putty version that you used on your load controller, please exchange it with the current version.
Recently, I had a similiar problem (I don't remember the exact error message or code) using the Performer built in .sep files when trying to connect to new SSH servers.
0 Likes
mysteini Absent Member.
Absent Member.

RE: How to fix?: RT: 75 - Custom error, Unable to establish the connection, errorcode: 6)

Jump to solution
Hey,

thanks for the info. I tried your possible fixes. It hasnt been the actual fix, but it helped me locate the error and fix it.
The problem hasnt been the version of the in the sep-file included putty.exe, but instead the wrong key exchange algorithm has been stored in the default settings.

I manually executed the putty.exe of the sep-file which led me to the error "ssh2_msg_unimplemented packet".
Changing the key exchange algorithm was the trick for me.

Thanks a lot for your suggestion. It helped a lot! :)
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.