Anonymous_User Absent Member.
Absent Member.
2925 views

11.4 device update fails if drive is encrypted

This is a repeat of an issue I had a few years ago. At least it is not
failing on every encrypted machine as it did before. On about half of our
encrypted machines the 11.4 update fails on the
novell-zenworks-fde-sec-11.4.0.338.x86_64.msi install. Looking in
novell-zenworks-fde-sec-11.4.0.338.x86_64.msi.log I see the following at the
fail point.

Action start 16:38:16: FSE_MSI_Branding.
MSI (s) (7C:E4) [16:38:16:940]: Skipping action: Error_NeedPassword
(condition is false)
MSI (s) (7C:E4) [16:38:16:940]: Doing action: Error_WrongPassword
Action ended 16:38:16: FSE_MSI_Branding. Return value 1.
Action start 16:38:16: Error_WrongPassword.
MSI (s) (7C:E4) [16:38:16:940]: Product: Novell® Full Disk Encryption -- The
administration password set in the policy file is incorrect. Please generate
a new policy file using the correct password. The upgrade procedure will now
abort.
The administration password set in the policy file is incorrect. Please
generate a new policy file using the correct password. The upgrade procedure
will now abort.
Action ended 16:38:16: Error_WrongPassword. Return value 3.
Action ended 16:38:16: INSTALL. Return value 3.

I can manually run the msi, put in the admin password and it works as I have
done in the past.

How is the installer determining the admin password? Obviously it is using
the wrong one on certain devices.

Jim Koerner
Server - ZCM 11.4 and Internal Database on Win2008R2x64
Clients - ZCM 11.4 and ZCM 11.3.2 FTF 1 on Win7SP1x64

0 Likes
15 Replies
Anonymous_User Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

Jim,

Jim, you and I worked on this a long time ago, back when I was with
Novell - this should have been fixed a long time since I think. Open a
SR and ask... 🙂

--

Shaun Pond
in my "day job" I work for ENGL; our aim is to make Windows deployment
easy


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

SR in the pipe again....

"Shaun Pond" wrote in message
news:VA.00010f92.10b3c162@no-mx.forums.novell.com...

Jim,

Jim, you and I worked on this a long time ago, back when I was with
Novell - this should have been fixed a long time since I think. Open a
SR and ask... 🙂

--

Shaun Pond
in my "day job" I work for ENGL; our aim is to make Windows deployment
easy

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

Jim,

🙂

--

Shaun Pond
in my "day job" I work for ENGL; our aim is to make Windows deployment
easy


0 Likes
hollffg Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

hi!

could you please post the solution here, we have the same issue with some of our machines.

regards
stefan
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: 11.4 device update fails if drive is encrypted

Are you getting the EXACT SAME errors in your logs about password.
I don't have the answer for you but..............I want to make sure you are not have the same symptom due to a different cause.
0 Likes
hollffg Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

This is from "5011040000fc50000000002015073012\novell-zenworks-fde-sec-11.4.0.338.x86_64.msi.log":
MSI (s) (CC:54) [12:46:58:610]: Closing MSIHANDLE (92) of type 790542 for thread 1652
Action start 12:46:58: FSE_MSI_Branding.
MSI (s) (CC:74) [12:46:58:610]: Skipping action: Error_NeedPassword (condition is false)
MSI (s) (CC:74) [12:46:58:610]: Doing action: Error_WrongPassword
Action ended 12:46:58: FSE_MSI_Branding. Return value 1.
Action start 12:46:58: Error_WrongPassword.
MSI (s) (CC:74) [12:46:58:610]: Product: Novell® Full Disk Encryption -- The administration password set in the policy file is incorrect. Please generate a new policy file using the correct password. The upgrade procedure will now abort.

The administration password set in the policy file is incorrect. Please generate a new policy file using the correct password. The upgrade procedure will now abort.
Action ended 12:46:58: Error_WrongPassword. Return value 3.
Action ended 12:46:58: INSTALL. Return value 3.


so yes, i think i got the same issue.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

Same as I am seeing and I have an SR going. Had a few sessions over the
last few days on one of my problem machines. Today and they collected some
stuff to review off line. Looks like the admin password stored on the
device does not match the latest one that is in ZCC -> "Emergency Recovery".
I'll post back once I know more.

Jim

"hollffg" wrote in message
news:hollffg.73pv9b@no-mx.forums.microfocus.com...


This is from
"5011040000fc50000000002015073012\novell-zenworks-fde-sec-11.4.0.338.x86_64.msi.log":
> MSI (s) (CC:54) [12:46:58:610]: Closing MSIHANDLE (92) of type 790542
> for thread 1652
> Action start 12:46:58: FSE_MSI_Branding.
> MSI (s) (CC:74) [12:46:58:610]: Skipping action: Error_NeedPassword
> (condition is false)
> MSI (s) (CC:74) [12:46:58:610]: Doing action: Error_WrongPassword
> Action ended 12:46:58: FSE_MSI_Branding. Return value 1.
> Action start 12:46:58: Error_WrongPassword.
> MSI (s) (CC:74) [12:46:58:610]: Product: Novell� Full Disk Encryption --
> The administration password set in the policy file is incorrect. Please
> generate a new policy file using the correct password. The upgrade
> procedure will now abort.
>
> The administration password set in the policy file is incorrect. Please
> generate a new policy file using the correct password. The upgrade
> procedure will now abort.
> Action ended 12:46:58: Error_WrongPassword. Return value 3.
> Action ended 12:46:58: INSTALL. Return value 3.


so yes, i think i got the same issue.


--
hollffg
------------------------------------------------------------------------
hollffg's Profile: https://forums.novell.com/member.php?userid=7381
View this thread: https://forums.novell.com/showthread.php?t=493818

0 Likes
hollffg Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

i did some comparing of identical machines where one fails and another one updates correctly.
i found that on the failing one, there are older versions of FDE still installed.
uninstalling the newer version (fde-msi only) didnt help

the real problem is that you cannot change the FDE policy anymore, even decrypting the disk results in unreadable disk.
at the moment all i can do is reinstall the device.

i hope they find a better solution.

regards
stefan
0 Likes
Adeckert1 Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

Same problem too.
We manually installed the novell-zenworks-fde-sec11.4.xxx.x86_64.msi. We followed TID 7010468. After that we have to decrypt the laptop with the emergency recovery CD. The problem reappeared in 11.4 Agent
I could not find any solution for this problem and any TID for 11.4.

regards
Andreas
0 Likes
Adeckert1 Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

Adeckert;2412088 wrote:
Same problem too.
We manually installed the novell-zenworks-fde-sec11.4.xxx.x86_64.msi. We followed TID 7010468. After that we have to decrypt the laptop with the emergency recovery CD. The problem reappeared in 11.4 Agent
I could not find any solution for this problem and any TID for 11.4.

regards
Andreas


PS: If you have custom DMI settings for PBA, then this will gone, please see the new TID 7017160 for this.
There is no simple solution. My solution: boot to PXE, mount the PBA Linux Partition and create there the custom DMI.ini in the PBA Linux Partition with your settings and reboot. That´s it.
0 Likes
Adeckert1 Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

Now I updated to 11.4.2 agent and I have the same error once more.
The TID 7017160 is wrong: it is not fixed in 11.4.2
MicroFocus: please correct it

Regards
Andreas
0 Likes
shaunpond Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

Adeckert,

use the feedback link on the TID, that goes to the author directly

--

Shaun Pond
in my "day job" I work for ENGL; our aim is to make Windows deployment
easy


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

Thought I would give an update on this issue. I went through an SR a while
back but no real resolution except that is was a known legacy issue.
Basically it only affected machines encrypted before before a certain ZCM
version. I got a reply that my SR had been resolved in 11.4.1 so I have
installed the update. First machine I tried to update gets the FDE msi
install failure just as before and the manual install workaround worked as
before.

from 11.4.1 readme:
Bug 943851 ZCM Agent SU Update fails if encrypted - component
novell-zenworks-fde-sec-11.4.0.338.x86_64.msi


Jim Koerner
Servers - ZCM 11.4.1 and Internal Database on Win2008R2x64 and Appliance
Clients - ZCM 11.4.1 and ZCM 11.4 FTF 1 on Win7SP1x64



"Jim Koerner" wrote in message
news:i1_Cx.793$Qq2.595@novprvlin0913.provo.novell.com...

This is a repeat of an issue I had a few years ago. At least it is not
failing on every encrypted machine as it did before. On about half of our
encrypted machines the 11.4 update fails on the
novell-zenworks-fde-sec-11.4.0.338.x86_64.msi install. Looking in
novell-zenworks-fde-sec-11.4.0.338.x86_64.msi.log I see the following at the
fail point.

Action start 16:38:16: FSE_MSI_Branding.
MSI (s) (7C:E4) [16:38:16:940]: Skipping action: Error_NeedPassword
(condition is false)
MSI (s) (7C:E4) [16:38:16:940]: Doing action: Error_WrongPassword
Action ended 16:38:16: FSE_MSI_Branding. Return value 1.
Action start 16:38:16: Error_WrongPassword.
MSI (s) (7C:E4) [16:38:16:940]: Product: Novell® Full Disk Encryption -- The
administration password set in the policy file is incorrect. Please generate
a new policy file using the correct password. The upgrade procedure will now
abort.
The administration password set in the policy file is incorrect. Please
generate a new policy file using the correct password. The upgrade procedure
will now abort.
Action ended 16:38:16: Error_WrongPassword. Return value 3.
Action ended 16:38:16: INSTALL. Return value 3.

I can manually run the msi, put in the admin password and it works as I have
done in the past.

How is the installer determining the admin password? Obviously it is using
the wrong one on certain devices.

Jim Koerner
Server - ZCM 11.4 and Internal Database on Win2008R2x64
Clients - ZCM 11.4 and ZCM 11.3.2 FTF 1 on Win7SP1x64

0 Likes
hollffg Absent Member.
Absent Member.

Re: 11.4 device update fails if drive is encrypted

Jim Koerner;2414342 wrote:
Thought I would give an update on this issue. I went through an SR a while
back but no real resolution except that is was a known legacy issue.
Basically it only affected machines encrypted before before a certain ZCM
version. I got a reply that my SR had been resolved in 11.4.1 so I have
installed the update. First machine I tried to update gets the FDE msi
install failure just as before and the manual install workaround worked as
before.

from 11.4.1 readme:
Bug 943851 ZCM Agent SU Update fails if encrypted - component
novell-zenworks-fde-sec-11.4.0.338.x86_64.msi


hi jim,
thanks for the update.
i can confirm that there is no improvement here at our site.
i rolled out update 11.4.1.5619 but still same problem with some of my devices.

is your SR still open?

regards,
stefan
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.