Anonymous_User Absent Member.
Absent Member.
1543 views

Deleting filter...

Hi

After creating af rule using filters I try to delete the filter
using "FilterDelete" but however nothing happens...?

I am using the commands in this order:
CreateObject
FilterCreate
FilterGroupBegin
FilterGroupBegin |
FilterSetItemType | x 5
FilterGroupEnd |
FilterGroupEnd
FilterApply
RuleCreate
RuleAddActionForward
FilterDelete

Any ideas what to do?

Thanks

Lars
Labels (1)
0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Deleting filter...

It looks fine. What's the issue. You've deleted the filter; that won't
delete the rule (which is what I think you are thinking)

--

<lan@caslan.com> wrote in message
news:zeNlc.574$Ob.555@prv-forum2.provo.novell.com...
> Hi
>
> After creating af rule using filters I try to delete the filter
> using "FilterDelete" but however nothing happens...?
>
> I am using the commands in this order:
> CreateObject
> FilterCreate
> FilterGroupBegin
> FilterGroupBegin |
> FilterSetItemType | x 5
> FilterGroupEnd |
> FilterGroupEnd
> FilterApply
> RuleCreate
> RuleAddActionForward
> FilterDelete
>
> Any ideas what to do?
>
> Thanks
>
> Lars



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Deleting filter...

Hello, Lars.

Deleting the filter clears the memory that is being used within
GroupWise to hold that filter. You should not see any results (other
then an Execute result of success) when you complete the FilterDelete
token.

Regards,

Shane

In article <zeNlc.574$Ob.555@prv-forum2.provo.novell.com>,
lan@caslan.com says...
> Hi
>
> After creating af rule using filters I try to delete the filter
> using "FilterDelete" but however nothing happens...?
>
> I am using the commands in this order:
> CreateObject
> FilterCreate
> FilterGroupBegin
> FilterGroupBegin |
> FilterSetItemType | x 5
> FilterGroupEnd |
> FilterGroupEnd
> FilterApply
> RuleCreate
> RuleAddActionForward
> FilterDelete
>
> Any ideas what to do?
>
> Thanks
>
> Lars
>

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Deleting filter...

Hi

When deleting the filter (not the rule) and I getting a Execute result,
the filter is still active on the client? But when shutting down the
client, and turning it back on - the filter is gone (and the rule still
exists) ! Seems like I have to make a refresh on the app after deleting
the filter?

Thoughts?

Lars

> Hello, Lars.
>
> Deleting the filter clears the memory that is being used within
> GroupWise to hold that filter. You should not see any results (other
> then an Execute result of success) when you complete the FilterDelete
> token.
>
> Regards,
>
> Shane
>
> In article <zeNlc.574$Ob.555@prv-forum2.provo.novell.com>,
> lan@caslan.com says...
> > Hi
> >
> > After creating af rule using filters I try to delete the filter
> > using "FilterDelete" but however nothing happens...?
> >
> > I am using the commands in this order:
> > CreateObject
> > FilterCreate
> > FilterGroupBegin
> > FilterGroupBegin |
> > FilterSetItemType | x 5
> > FilterGroupEnd |
> > FilterGroupEnd
> > FilterApply
> > RuleCreate
> > RuleAddActionForward
> > FilterDelete
> >
> > Any ideas what to do?
> >
> > Thanks
> >
> > Lars
> >


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.