Anonymous_User Absent Member.
Absent Member.
2350 views

GW Admin API installation problem.

Hi,

I am having problems with getting a workable GW Admin API on my machine.
At first I couldn't regsiter GWCMB1.DLL. I then saw it was missing
dependencies to calwin32.dll and clxwin32.dll. I copied these into the
grouwpise folder where GWCMB1.dll lived and then could register the same.
This however does not solve my problem. When I run the gwadmin vb from
samples I get an "80010108" automation error when it attempt to cnnect to
the domain DB. I also get a clsid not found from my vb.net app when I
reference an admin class. The clsid is truly missing but I don't know
what is should be. I have tried renstalling Groupwise but i did not help.

I am not running the Netware client for windows (nor can I in this case).
Could this be the problem?
Labels (1)
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: GW Admin API installation problem.

kconnelly@ali-inc.com schrieb:
> Hi,
>
> I am having problems with getting a workable GW Admin API on my machine.
> At first I couldn't regsiter GWCMB1.DLL. I then saw it was missing
> dependencies to calwin32.dll and clxwin32.dll. I copied these into the
> grouwpise folder where GWCMB1.dll lived and then could register the same.
> This however does not solve my problem. When I run the gwadmin vb from
> samples I get an "80010108" automation error when it attempt to cnnect to
> the domain DB. I also get a clsid not found from my vb.net app when I
> reference an admin class. The clsid is truly missing but I don't know
> what is should be. I have tried renstalling Groupwise but i did not help.
>
> I am not running the Netware client for windows (nor can I in this case).
> Could this be the problem?


i we can trust the gw admin api doc -> the only thing needed is a 32 bit
groupwise version ....

but i would try to install a novell client
0 Likes
skirkby Absent Member.
Absent Member.

Re: GW Admin API installation problem.

My experience is that you need Client32. The AOAPI wants to keep any changes in sync with NDS, just like the C1 snapin does.

I've never been able to connect to a domain DB without being logged into its tree first.

--sk.

>>> <kconnelly@ali-inc.com> 8/4/2004 9:02:16 AM >>>


Hi,

I am having problems with getting a workable GW Admin API on my machine.
At first I couldn't regsiter GWCMB1.DLL. I then saw it was missing
dependencies to calwin32.dll and clxwin32.dll. I copied these into the
grouwpise folder where GWCMB1.dll lived and then could register the same.
This however does not solve my problem. When I run the gwadmin vb from
samples I get an "80010108" automation error when it attempt to cnnect to
the domain DB. I also get a clsid not found from my vb.net app when I
reference an admin class. The clsid is truly missing but I don't know
what is should be. I have tried renstalling Groupwise but i did not help.

I am not running the Netware client for windows (nor can I in this case).
Could this be the problem?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.