d_shvedov Absent Member.
Absent Member.
2980 views

Stubbing activating

Hi,

I have enabled stubbing according documentation (trusted application is registered, archive server address and port are supplied, web service on archive server is running) .
But if I am trying to open a stubbed email in Windows client is nothing happen. Groupwise don't call the archive server (I checked it with trafiic monitor on both sides).
I see an empty email and couldn't find warnings or errors. I set warning level on POA to verbose but it didn't help.
What should I check or where can I see errors messages?

Thanks,
Dmitriy
Labels (1)
0 Likes
5 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Stubbing activating

You have to setup to use an archive server in
to places in ConsoleOne.
Select the "GroupWise System" line.
From the menu, select "Tools" / "System Preferences...".
Select the "Archive Service Settings" tab.
In the combo box, select your trusted app.
If you don't see your trusted app, you will need
to go back to the "Trusted Application.." page
and enable your trusted application to
"Allow access to Archive Service".

Make sure the POA's and MTA's are running and
the updates are propagated to all of the POA's.

There were some changes to the GWClient. Make sure
you have 8.0.1 HP1.

Preston


>>> On Tuesday, April 13, 2010 at 5:16 AM, d

shvedov<d_shvedov@no-mx.forums.novell.com> wrote:

> Hi,
>
> I have enabled stubbing according documentation (trusted application is
> registered, archive server address and port are supplied, web service on
> archive server is running) .
> But if I am trying to open a stubbed email in Windows client is nothing
> happen. Groupwise don't call the archive server (I checked it with
> trafiic monitor on both sides).
> I see an empty email and couldn't find warnings or errors. I set
> warning level on POA to verbose but it didn't help.
> What should I check or where can I see errors messages?
>
> Thanks,
> Dmitriy

0 Likes
d_shvedov Absent Member.
Absent Member.

Re: Stubbing activating

Hi Preston,
thank you for your answer.

I checked my Groupwise:
- GW Client shows: version 8.0.1 08.01.2010,
- System Preferences: Trasted Application is selected,
- "Trusted Applcation" page: "Allow access to Archive Service" is activated.
But I found here something:
1) if I specify "DNS Hostname" as http://server/MyService.asmx and "Port" as 7151 -> it shows me http://server/MyService.asmx:7151
In this case if I make double click on stubbed mail, GW client shows error: "Error [ea10] downloading item from remote server - "Missing session string""
2) if I specify "DNS hostname" as http://server:7151/MyService.asmx and "Port" leave empty -> it shows me http://server:7151/MyService.asmx
If I make double click on stubbed mail GW client don't show error.
3) if I specify "DNS hostname" as http://server/MyService.asmx and "Port" leave empty -> it shows me http://server/MyService.asmx
If I make double click on stubbed mail GW client don't show error.

In all cases Groupwise don't call archive web service.

What is the right way to specify hostname and port: 1 or 2?
Are there any possibilty to switch on the logging/trace for stubbing/archiv service?

Thank you!
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Stubbing activating

On 4/16/2010 6:46 AM, d shvedov wrote:
>
> Hi Preston,
> thank you for your answer.
>
> I checked my Groupwise:
> - GW Client shows: version 8.0.1 08.01.2010,
> - System Preferences: Trasted Application is selected,
> - "Trusted Applcation" page: "Allow access to Archive Service" is
> activated.
> But I found here something:
> 1) if I specify "DNS Hostname" as http://server/MyService.asmx and
> "Port" as 7151 -> it shows me http://server/MyService.asmx:7151
> In this case if I make double click on stubbed mail, GW client shows
> error: "Error [ea10] downloading item from remote server - "Missing
> session string""
> 2) if I specify "DNS hostname" as http://server:7151/MyService.asmx and
> "Port" leave empty -> it shows me http://server:7151/MyService.asmx
> If I make double click on stubbed mail GW client don't show error.
> 3) if I specify "DNS hostname" as http://server/MyService.asmx and
> "Port" leave empty -> it shows me http://server/MyService.asmx
> If I make double click on stubbed mail GW client don't show error.
>
> In all cases Groupwise don't call archive web service.
>
> What is the right way to specify hostname and port: 1 or 2?
> Are there any possibilty to switch on the logging/trace for
> stubbing/archiv service?
>
> Thank you!
>
>

You don't add the path

just ip:port or dns:port

the path is hardcoded to /gwarchive

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Stubbing activating

On 4/16/2010 8:38 AM, Michael Bell wrote:
> On 4/16/2010 6:46 AM, d shvedov wrote:
>>
>> Hi Preston,
>> thank you for your answer.
>>
>> I checked my Groupwise:
>> - GW Client shows: version 8.0.1 08.01.2010,
>> - System Preferences: Trasted Application is selected,
>> - "Trusted Applcation" page: "Allow access to Archive Service" is
>> activated.
>> But I found here something:
>> 1) if I specify "DNS Hostname" as http://server/MyService.asmx and
>> "Port" as 7151 -> it shows me http://server/MyService.asmx:7151
>> In this case if I make double click on stubbed mail, GW client shows
>> error: "Error [ea10] downloading item from remote server - "Missing
>> session string""
>> 2) if I specify "DNS hostname" as http://server:7151/MyService.asmx and
>> "Port" leave empty -> it shows me http://server:7151/MyService.asmx
>> If I make double click on stubbed mail GW client don't show error.
>> 3) if I specify "DNS hostname" as http://server/MyService.asmx and
>> "Port" leave empty -> it shows me http://server/MyService.asmx
>> If I make double click on stubbed mail GW client don't show error.
>>
>> In all cases Groupwise don't call archive web service.
>>
>> What is the right way to specify hostname and port: 1 or 2?
>> Are there any possibilty to switch on the logging/trace for
>> stubbing/archiv service?
>>
>> Thank you!
>>
>>

> You don't add the path
>
> just ip:port or dns:port
>
> the path is hardcoded to /gwarchive
>


To further clarify. If your dns name or your server is
stubbing.mycompany.com, and the port your service runs on is 5678 you enter

stubbing.mycompany.com and the port of 5678

It will then automatically do http (or https, based on ssl setting),
stubbing.mycompany.com:5678/gwarchive

0 Likes
d_shvedov Absent Member.
Absent Member.

Re: Stubbing activating

Thanks! It was wrong.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.