Micro Focus Expert
Micro Focus Expert
1107 views

Too many email addresses

Hi,

In Hungary the name of users can contain accented characters. When I set GW to generate email addresses in Last Name.First Name@Internet domain name format, these accented characters are not removed from the email address, so they are not valid. I wrote a script to get rid of the accents, but the result is not what I expected.

This is the xml I make for every user:

<?xml version="1.0" encoding="UTF-8"?>
<user xmlns:ns2="http://www.w3.org/2005/Atom">
<preferredAddressFormat>
<inherited>false</inherited>
<inheritedFrom>DOMAIN</inheritedFrom>
<inheritedValue>LAST_FIRST</inheritedValue>
<value>LAST_FIRST</value>
</preferredAddressFormat>
<preferredEmailId>horvath.gellert</preferredEmailId>
<internetDomainName>
<inherited>false</inherited>
<value>domain</value>
</internetDomainName>
<emailAddresses>horvath.gellert@domain</emailAddresses>
</user>

curl -k -H "Content-Type: application/xml" -X PUT --user user:password --data "@./horvathg-import.xml" https://mail:9710/gwadmin-service/domains/DOMAIN/postoffices/POSOFFICE/users/horvathg

When I load this into GW everything looks fine, the attributes are set correctly. But when I click View EMail Addresses in GW Admin console, there are 40 email addresses in the allowed addresses formats, although "For incoming mail, recipients are known exclusively by this Internet domain name" is set. User is addressable through theses 40 email addresses, and makes conflicts when I try to create an email address with the same referredEmailId but with a different domain.

When I click "save" without any modification made on the user's properties page and open "View EMail Addresses" again, then there are only the two required email addresses. How can I automate this? There is nothing in the dev docs about a "save" feature. Clicking save on 30k user is not an option.

Thanks,
Gellert
Labels (1)
0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

Re: Too many email addresses

Update.

I changed the Internet Addressing Email Publishing to "Publish the Preferred Email Address only" and now there are only the two expected email addresses on the users property page. This solves my problem, ( but I will open an SR for the previous scenario.)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.