mdirkse Absent Member.
Absent Member.
1259 views

Very wierd SOAP service stalling problem in vm-based GW8

Hi,
I'm facing a very weird problem on the GroupWise server that I'm using to test my archiving app. I'm talking to the SOAP interface via java client, and whenever I run any kind of test that does several SOAP call, the test will invariably hang on some call (not a fixed one) and refuse to budge.

Now here's the weird part: if I then log into the Groupwise a groupwise client that's talking to the same groupwise server, by test becomes unstuck and starts to move forward again. It will then stall again, until I click on an email in the GW client interface (ie initiate more communication with the server), at which point it'll move again. I have to open several emails in order my test to complete.
This is very strange: in order for the SOAP service to function, I seem to have to egg on the Groupwise server by making requests through the client.

Anyone have any ideas? My Groupwise is version 8.0.0, which I'm running on SuSe 11 on a VM on ESXi 4. The client was compiled using the standard GroupWise WSDL.

Regards,
Maarten
Labels (1)
Tags (1)
0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Very weird SOAP service stalling problem in vm-based GW8

I haven't heard of a problem like that.
You can try 8.0.2. There have been significant
improvements in the SOAP code. You can look
with the web browser interface at the POA to
see what the SOAP threads are doing. (Note:
There is more information about the SOAP
threads in 8.0.2.)

You could also try the javaClient from the
SOAP SDK to see if it has the same problem.

There are some SOAP request, if not made
correctly, that can take a long time to
complete. You could do a SOAP trace to see
what is going on.

Preston

>>> On Wednesday, August 11, 2010 at 6:06 AM,

mdirkse<mdirkse@no-mx.forums.novell.com> wrote:

> Hi,
> I'm facing a very weird problem on the GroupWise server that I'm using
> to test my archiving app. I'm talking to the SOAP interface via java
> client, and whenever I run any kind of test that does several SOAP call,
> the test will invariably hang on some call (not a fixed one) and refuse
> to budge.
>
> Now here's the weird part: if I then log into the Groupwise a groupwise
> client that's talking to the same groupwise server, by test becomes
> unstuck and starts to move forward again. It will then stall again,
> until I click on an email in the GW client interface (ie initiate more
> communication with the server), at which point it'll move again. I have
> to open several emails in order my test to complete.
> This is very strange: in order for the SOAP service to function, I seem
> to have to egg on the Groupwise server by making requests through the
> client.
>
> Anyone have any ideas? My Groupwise is version 8.0.0, which I'm running
> on SuSe 11 on a VM on ESXi 4. The client was compiled using the standard
> GroupWise WSDL.
>
> Regards,
> Maarten

0 Likes
mdirkse Absent Member.
Absent Member.

Re: Very weird SOAP service stalling problem in vm-based GW8

Hi Preston,
Thanks for your reply. In the mean time I've heard from a bunch of other people as well that 8.0.2 is more stable on the SOAP front. I'll upgrade and see if the problem persists.
BTW, I don't think my soap requests are incorrectly formed or anything like that. It's not that they complete slowly, it's that they don' complete at all unless I do something in the client.
Regards,
Maarten

Preston Stephenson;2009378 wrote:
I haven't heard of a problem like that.
You can try 8.0.2. There have been significant
improvements in the SOAP code. You can look
with the web browser interface at the POA to
see what the SOAP threads are doing. (Note:
There is more information about the SOAP
threads in 8.0.2.)

You could also try the javaClient from the
SOAP SDK to see if it has the same problem.

There are some SOAP request, if not made
correctly, that can take a long time to
complete. You could do a SOAP trace to see
what is going on.

Preston

>>> On Wednesday, August 11, 2010 at 6:06 AM,

mdirkse<mdirkse@no-mx.forums.novell.com> wrote:

> Hi,
> I'm facing a very weird problem on the GroupWise server that I'm using
> to test my archiving app. I'm talking to the SOAP interface via java
> client, and whenever I run any kind of test that does several SOAP call,
> the test will invariably hang on some call (not a fixed one) and refuse
> to budge.
>
> Now here's the weird part: if I then log into the Groupwise a groupwise
> client that's talking to the same groupwise server, by test becomes
> unstuck and starts to move forward again. It will then stall again,
> until I click on an email in the GW client interface (ie initiate more
> communication with the server), at which point it'll move again. I have
> to open several emails in order my test to complete.
> This is very strange: in order for the SOAP service to function, I seem
> to have to egg on the Groupwise server by making requests through the
> client.
>
> Anyone have any ideas? My Groupwise is version 8.0.0, which I'm running
> on SuSe 11 on a VM on ESXi 4. The client was compiled using the standard
> GroupWise WSDL.
>
> Regards,
> Maarten
0 Likes
mdirkse Absent Member.
Absent Member.

Re: Very weird SOAP service stalling problem in vm-based GW8

Upgrading to 8.0.2 did indeed solve this problem.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.