Anonymous_User Absent Member.
Absent Member.
1183 views

forwarding emails...

Hi all,

I have a question about forwarding emails using the SOAP API. I need to
forward some emails from a GW mailbox to a given email address, which might
be another GW mailbox on the same post office or it might be an external
email address.

I'm using forwardRequest to get the forward item and use this view: "default
peek message attachments" to get email data. I add a single extra attachment
to the forwarded email and change the subject. When I use sendItemRequest to
send the mail, it seems that attachments are not forwarded. I only get
attachments from the original email if I download them one-by-one and attach
them to the mail item that was returned by forwardRequest. Is this the
correct behavior or am I missing something here?

I'm using GW 7.0.3.

Thanks,
Gyorgy Bozoki


Labels (1)
0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: forwarding emails...

Sorry, it will be awhile before I can try this.
I created a bug to track the information.
I'll post a reply when I look into the problem.

Preston

>>> On Tuesday, July 01, 2008 at 2:53 PM, gb<nospam@nospam.com> wrote:

> Hi all,
>
> I have a question about forwarding emails using the SOAP API. I need to
> forward some emails from a GW mailbox to a given email address, which

might
> be another GW mailbox on the same post office or it might be an external
> email address.
>
> I'm using forwardRequest to get the forward item and use this view:

"default
>
> peek message attachments" to get email data. I add a single extra

attachment
>
> to the forwarded email and change the subject. When I use sendItemRequest

to
>
> send the mail, it seems that attachments are not forwarded. I only get
> attachments from the original email if I download them one-by-one and

attach
> them to the mail item that was returned by forwardRequest. Is this the
> correct behavior or am I missing something here?
>
> I'm using GW 7.0.3.
>
> Thanks,
> Gyorgy Bozoki

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: forwarding emails...

Thank you, Preston. I'll try once more to see if I messed up something, but
it seems that when I send the item from forwardRequest, I get the attachment
icons in the received email but the attached files are not there. So I have
to download all attachments from the original message and attach them to the
one being sent as the forwarded message.


"Preston Stephenson" <PStephenson@gw.novell.com> wrote in message
news:487364D8.07F1.0037.1@gw.novell.com...
> Sorry, it will be awhile before I can try this.
> I created a bug to track the information.
> I'll post a reply when I look into the problem.
>
> Preston
>
>>>> On Tuesday, July 01, 2008 at 2:53 PM, gb<nospam@nospam.com> wrote:

>> Hi all,
>>
>> I have a question about forwarding emails using the SOAP API. I need to
>> forward some emails from a GW mailbox to a given email address, which

> might
>> be another GW mailbox on the same post office or it might be an external
>> email address.
>>
>> I'm using forwardRequest to get the forward item and use this view:

> "default
>>
>> peek message attachments" to get email data. I add a single extra

> attachment
>>
>> to the forwarded email and change the subject. When I use sendItemRequest

> to
>>
>> send the mail, it seems that attachments are not forwarded. I only get
>> attachments from the original email if I download them one-by-one and

> attach
>> them to the mail item that was returned by forwardRequest. Is this the
>> correct behavior or am I missing something here?
>>
>> I'm using GW 7.0.3.
>>
>> Thanks,
>> Gyorgy Bozoki



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: forwarding emails...

I've entered a bug for this. I don't have a workaround.

Preston

>>> On Tuesday, July 08, 2008 at 1:00 PM, Preston

Stephenson<PStephenson@gw.novell.com> wrote:
> Sorry, it will be awhile before I can try this.
> I created a bug to track the information.
> I'll post a reply when I look into the problem.
>
> Preston
>
>>>> On Tuesday, July 01, 2008 at 2:53 PM, gb<nospam@nospam.com> wrote:

>> Hi all,
>>
>> I have a question about forwarding emails using the SOAP API. I need to
>> forward some emails from a GW mailbox to a given email address, which

> might
>> be another GW mailbox on the same post office or it might be an external


>> email address.
>>
>> I'm using forwardRequest to get the forward item and use this view:

> "default
>>
>> peek message attachments" to get email data. I add a single extra

> attachment
>>
>> to the forwarded email and change the subject. When I use

sendItemRequest
> to
>>
>> send the mail, it seems that attachments are not forwarded. I only get
>> attachments from the original email if I download them one-by-one and

> attach
>> them to the mail item that was returned by forwardRequest. Is this the
>> correct behavior or am I missing something here?
>>
>> I'm using GW 7.0.3.
>>
>> Thanks,
>> Gyorgy Bozoki

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.